Bug 168223 - yum list with asterisk doesn't work consistently
yum list with asterisk doesn't work consistently
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 13:03 EDT by Jason Powers
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Powers 2005-09-13 13:03:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
OK since Fedora was first released this minor tweaky thing has been a problem. RPM never did this right at all, so I never complained, but now that I'm spending a lot of time with this software it's a problem.

I never use rhnsd, I always use yum. Generally it works jsut fine. When I want to install a package or just look at what's available, say for python, I use "yum list python*". I'm used to command-line work so it makes sense to me to be able to throw an asterisk in there. However, most of your packages will be listed "python-whatever", which makes it easier to read the titles. SOME packages will not return in the list if you just put python* instead of python-*. It's the same with the perl set and as I found out today, the same with the tomcat packages. 

I ran two commands to illustrate, note one returns NOTHING and the other returns the correct list. If this can't be fixed it should be in the documentation for yum, since it's clearly the '-' symbol causing the problem. This has been the same problem all along, but like I said it's so minor it seemed better not to clutter up bugzilla with it. This is a brand new 'everything' install of FC4.i386, no customization except for the extra repo for jpackage, it has no effect: 

[root@peridot tomcat5]# yum list tomcat5*
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
jpackage-generic          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
jpackage-fc               100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 295 kB    00:01
updates-re: ################################################## 918/918
Added 22 new packages, deleted 2 old in 1.33 seconds
[root@peridot tomcat5]# yum list tomcat5-*
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
jpackage-generic          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
jpackage-fc               100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Installed Packages
tomcat5.noarch                           5.0.30-8jpp            installed
tomcat5-admin-webapps.noarch             5.0.30-8jpp            installed
tomcat5-jasper.noarch                    5.0.30-8jpp            installed
tomcat5-jasper-javadoc.noarch            5.0.30-8jpp            installed
tomcat5-servlet-2.4-api.noarch           5.0.30-8jpp            installed
tomcat5-servlet-2.4-api-javadoc.noarch   5.0.30-8jpp            installed
tomcat5-webapps.noarch                   5.0.30-8jpp            installed
Available Packages
tomcat5.i386                             5.0.30-5jpp_6fc        base
tomcat5-admin-webapps.i386               5.0.30-5jpp_6fc        base
tomcat5-jasper.i386                      5.0.30-5jpp_6fc        base
tomcat5-jasper-javadoc.i386              5.0.30-5jpp_6fc        base
tomcat5-servlet-2.4-api.i386             5.0.30-5jpp_6fc        base
tomcat5-servlet-2.4-api-javadoc.i386     5.0.30-5jpp_6fc        base
tomcat5-webapps.i386                     5.0.30-5jpp_6fc        base
[root@peridot tomcat5]#


Version-Release number of selected component (if applicable):
all versions to date

How reproducible:
Always

Steps to Reproduce:
1. type yum list python* and put that in a text file
2. type yum list python-* and put that in a text file
3. diff them or just run them back to back and compare at the command line

Actual Results:  the second one is longer, it returns more packages. it should return LESS if there are any packages that lack the '-' symbol; there is only one and it returns both.

Expected Results:  they should have been the same or the second should have been one item shorter

Additional info:

the easiest tests are python* and perl*, there's a lot of extras and such so you get a good list for each, but the lists are very different.
Comment 1 Seth Vidal 2005-09-13 13:23:37 EDT
are you escaping the * or not?

if you're not then probably your shell is expanding them.

Comment 2 Jason Powers 2005-09-13 14:00:16 EDT
I'm not escaping anything, I put exactly what is entered at the prompt, it's the
standard bash shell that comes with the initial install. 

The results are not following any pattern that suggests it's expanding at the
shell. look at the different package names that show up when I list python
(check out Avalable Packages for each):

[root@peridot ~]# yum list python*
Setting up repositories
updates-released          100% |=========================|  951 B    00:00     
jpackage-generic          100% |=========================|  951 B    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
base                      100% |=========================| 1.1 kB    00:00     
jpackage-fc               100% |=========================|  951 B    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 695 kB    00:09     
extras    : ################################################## 1962/1962
Added 1 new packages, deleted 84 old in 1.80 seconds
Installed Packages
python.i386                              2.4.1-2                installed       
python-HTMLgen.noarch                    2.2.2-7.fc4            installed       
python-adns.i386                         1.1.0-1                installed       
python-amara.noarch                      0.9.4-7.fc4            installed       
python-bibtex.i386                       1.2.1-2                installed       
python-cherrypy.noarch                   2.0.0-2.fc4            installed       
python-cherrytemplate.noarch             1.0.0-2.fc4            installed       
python-crypto.i386                       2.0.1-1.fc4            installed       
python-dateutil.noarch                   1.0-1.fc4              installed       
python-devel.i386                        2.4.1-2                installed       
python-dialog.noarch                     2.7-1.fc4              installed       
python-docs.noarch                       2.4.1-1                installed       
python-docutils.noarch                   0.3.9-1.fc4            installed       
python-durus.i386                        3.0-1.fc4              installed       
python-elementtree.i386                  1.2.6-4                installed       
python-goopy.noarch                      0.1-1                  installed       
python-imaging.i386                      1.1.4-9                installed       
python-imaging-devel.i386                1.1.4-9                installed       
python-irclib.noarch                     0.4.5-1.fc4            installed       
python-kid.noarch                        0.6.4-1.fc4            installed       
python-lcms.i386                         1.14-3                 installed       
python-ldap.i386                         2.0.6-4                installed       
python-logilab-common.noarch             0.10.0-1.fc4           installed       
python-matplotlib.i386                   0.83.2-2.fc4           installed       
python-numarray.i386                     1.3.3-4.fc4            installed       
python-numeric.i386                      23.7-2                 installed       
python-protocols.i386                    0.9.3-5.fc4            installed       
python-psyco.i386                        1.4-5.fc4              installed       
python-psycopg.i386                      1.1.19-1.fc4           installed       
python-quixote.i386                      2.1-1.fc4              installed       
python-reportlab.noarch                  1.20-3.fc4             installed       
python-simpletal.noarch                  3.12-4.fc4             installed       
python-sqlite.i386                       1.1.6-1                installed       
python-tools.i386                        2.4.1-2                installed       
python-tpg.noarch                        3.0.5-4.fc4            installed       
python-twisted.i386                      1.3.0-4                installed       
python-twisted-docs.i386                 1.3.0-2                installed       
python-urlgrabber.noarch                 2.9.6-1                installed       
Available Packages
python-durus.i386                        1.5-2                  extras          
python-psycopg.i386                      1.1.18-4.fc4           extras          
python-quixote.i386                      2.0-1                  extras          
python-reportlab.i386                    1.19-2                 extras          
[root@peridot ~]# yum list python-*
Setting up repositories
updates-released          100% |=========================|  951 B    00:00     
jpackage-generic          100% |=========================|  951 B    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
base                      100% |=========================| 1.1 kB    00:00     
jpackage-fc               100% |=========================|  951 B    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 723 kB    00:02     
extras    : ################################################## 2045/2045
Added 84 new packages, deleted 1 old in 2.12 seconds
Installed Packages
python.i386                              2.4.1-2                installed       
python-HTMLgen.noarch                    2.2.2-7.fc4            installed       
python-adns.i386                         1.1.0-1                installed       
python-amara.noarch                      0.9.4-7.fc4            installed       
python-bibtex.i386                       1.2.1-2                installed       
python-cherrypy.noarch                   2.0.0-2.fc4            installed       
python-cherrytemplate.noarch             1.0.0-2.fc4            installed       
python-crypto.i386                       2.0.1-1.fc4            installed       
python-dateutil.noarch                   1.0-1.fc4              installed       
python-devel.i386                        2.4.1-2                installed       
python-dialog.noarch                     2.7-1.fc4              installed       
python-docs.noarch                       2.4.1-1                installed       
python-docutils.noarch                   0.3.9-1.fc4            installed       
python-durus.i386                        3.0-1.fc4              installed       
python-elementtree.i386                  1.2.6-4                installed       
python-goopy.noarch                      0.1-1                  installed       
python-imaging.i386                      1.1.4-9                installed       
python-imaging-devel.i386                1.1.4-9                installed       
python-irclib.noarch                     0.4.5-1.fc4            installed       
python-kid.noarch                        0.6.4-1.fc4            installed       
python-lcms.i386                         1.14-3                 installed       
python-ldap.i386                         2.0.6-4                installed       
python-logilab-common.noarch             0.10.0-1.fc4           installed       
python-matplotlib.i386                   0.83.2-2.fc4           installed       
python-numarray.i386                     1.3.3-4.fc4            installed       
python-numeric.i386                      23.7-2                 installed       
python-protocols.i386                    0.9.3-5.fc4            installed       
python-psyco.i386                        1.4-5.fc4              installed       
python-psycopg.i386                      1.1.19-1.fc4           installed       
python-quixote.i386                      2.1-1.fc4              installed       
python-reportlab.noarch                  1.20-3.fc4             installed       
python-simpletal.noarch                  3.12-4.fc4             installed       
python-sqlite.i386                       1.1.6-1                installed       
python-tools.i386                        2.4.1-2                installed       
python-tpg.noarch                        3.0.5-4.fc4            installed       
python-twisted.i386                      1.3.0-4                installed       
python-twisted-docs.i386                 1.3.0-2                installed       
python-urlgrabber.noarch                 2.9.6-1                installed       
Available Packages
python-reportlab.i386                    1.19-2                 extras          
[root@peridot ~]# 


Is it maybe searching through a comment field or descriptor in a database rather
than the title of the file? I'm thinking maybe there's something going on that
verifies the name of the package where the names aren't as systematic as the
python-whatever package file names.
Comment 3 Seth Vidal 2005-09-13 14:05:43 EDT
are you using a mirrorlist?
Comment 4 Jason Powers 2005-09-13 14:09:29 EDT
Yeah that's the default now, right? Like I said I just installed it and left it
alone. I wouldn't have posted the bug except I was hoping future versions would
work out of the box.
Comment 5 Seth Vidal 2005-09-13 14:14:06 EDT
it's just a mirror that is out of sync. Notice the package counts on those two
list commands? One is 1962 the other is 2045. A mirror is not in sync and your
system is connecting to it and reading the data from there. Hence the problem.
It's not a bug in yum - but it is a mirror problem.

Note You need to log in before you can comment on or make changes to this bug.