Bug 168225 - P4/Xeon CPU frequency control support (P1)
P4/Xeon CPU frequency control support (P1)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
: FutureFeature
Depends On:
Blocks: 170417 185135 186960
  Show dependency treegraph
 
Reported: 2005-09-13 13:19 EDT by Issue Tracker
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 15:29:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linux-2.4.21-cpufreq-fix.patch (451 bytes, patch)
2005-09-13 13:23 EDT, Larry Troan
no flags Details | Diff

  None (edit)
Description Issue Tracker 2005-09-13 13:19:57 EDT
Escalated to Bugzilla from IssueTracker
Comment 3 Issue Tracker 2005-09-13 13:20:14 EDT
From User-Agent: XML-RPC

The following patch is required for RHEL3 cpufreq to function properly.

The original code tried to call cpufreq_set_policy() NR_CPUS(=32) times

and fail, regardless of the number of CPUs installed in the system.  The

patch solves this problem by calling cpu_online() to check if the CPU

exists before calling cpufreq_set_policy().



Status set to: Waiting on Tech

This event sent from IssueTracker by ltroan
 issue 79218
Comment 4 Issue Tracker 2005-09-13 13:20:22 EDT
From User-Agent: XML-RPC

This looks like Intel SpeedStep which is in U6.  Specific request however
is to enable "CONFIG_CPU_FREQ" and "CONFIG_CPU_FREQ_24_API" and
"CONFIG_X86_P4_CLOCKMOD" in the kernel.


Issue escalated to Feature-RHEL by: ltroan.
ltroan assigned to issue for NEC-Engineering.

Category set to: Kernel::Subsystems

Internal Status set to 'Waiting on Product Mgmt'

This event sent from IssueTracker by ltroan
 issue 79218
Comment 6 Larry Troan 2005-09-13 13:23:55 EDT
Created attachment 118767 [details]
linux-2.4.21-cpufreq-fix.patch
Comment 7 Larry Troan 2005-10-13 16:50:54 EDT
> > NEC, please confirm that this feature is included in RHEL4U2 per "Event posted
> > 09-13-2005 07:21pm by tatsu@ab.jp.nec.com" and close this issue.
> >
> The code is there, but it is not configured in the kernel (unless this is 
> changed after kernel-2.6.9-22.EL).  The feature request is to enable the 
> configuration CONFIG_CPU_FREQ_PROC_INTF in the kernel.

This request is to provide equivalent function in RHEL3U7.

Adding PM ACK since this is different than the Intel SpeedStep already delivered. 
Comment 9 Larry Troan 2005-11-01 16:28:18 EST
Can we get a QA ACK on this?

The feature request is to enable the configuration CONFIG_CPU_FREQ_PROC_INTF in
the kernel.

Comment 11 Peter Martuccelli 2005-12-15 09:26:58 EST
Moving to RHEL3 U8 Proposed list.
Comment 15 Larry Troan 2006-02-20 13:48:12 EST
NEC comments that they have blades that run very hot without the ability to
scale back the CPU frequency (and therefore the power) during idle times. In
RHEL4 with the 2.6 kernel there are other mechanisms to provide this capability
but in RHEL3 there is no other option.
Comment 16 Kosuke TATSUKAWA 2006-02-22 05:54:26 EST
The reason we need this feature is as mentioned in the previous comment.

> Bug is changed to "NEC Confidential" due to some of the comment content (was
> public). If NEC is OK with opening this bug to the public, we can reopen it.
Yes, it's OK to reopen this bug to public.
Comment 17 Peter Martuccelli 2006-03-30 15:29:01 EST
Engineering is not committing this for RHEL3, the changes are too large to be
considered for U8.  Closing this request out as wont fix.

Note You need to log in before you can comment on or make changes to this bug.