Bug 168236 - Negation of boolean search doesn't stick
Negation of boolean search doesn't stick
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.4
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
: 203595 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 15:15 EDT by Suzanne Hillman
Modified: 2013-06-23 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 12:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-09-13 15:15:11 EDT
Description of problem:
If you are trying to do a report which includes negation of the boolean table,
the negation part gets dropped.

How reproducible:
Always

Steps to Reproduce:
1. Set up a report search, such as one involving RHEL and IT associated bugs
whose status changed in a time period, and whose boolean search on 'comments
changed after' is negated.
2. Run the report
3. The negation is lost.
  
Actual results:
The negation should be kept, and when one goes to edit the search, it should
show up there, too.

Expected results:
Negation kept, search ran as expected.

Additional info:
Comment 1 David Lawrence 2006-08-22 14:20:35 EDT
*** Bug 203595 has been marked as a duplicate of this bug. ***
Comment 2 David Lawrence 2008-09-16 12:53:30 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 3 Suzanne Hillman 2008-09-16 13:27:25 EDT
This bug appears to still exist. The negation does show up in a 'edit search' view, but does not get reflected in the results.
Comment 4 David Lawrence 2008-12-01 14:52:52 EST
Moving to ASSIGNED as this bug has been reverified and will need further investigation.
Comment 5 David Lawrence 2010-01-15 11:55:22 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 6 Jan Kratochvil 2010-01-15 12:35:45 EST
Verified as fixed.

Note You need to log in before you can comment on or make changes to this bug.