Bug 168237 - unable to rebuild source rpm on ppc only
Summary: unable to rebuild source rpm on ppc only
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils   
(Show other bugs)
Version: 4.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Akira Imamura
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-13 19:22 UTC by John Poelstra
Modified: 2007-11-30 22:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 15:22:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Poelstra 2005-09-13 19:22:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
Customers will run into this issue because we don't provide the glib2-devel*ppc64 package in the regular distro

#  ppc64 rpmbuild --rebuild --define 'debug_package %{nil}' --target=ppc64 /mnt/redhat/beehive/updates/dist/4AS/SRPMS/diskdumputils-1.1.9-4.src.rpm
Installing /mnt/redhat/beehive/updates/dist/4AS/SRPMS/diskdumputils-1.1.9-4.src.rpm
Building target platforms: ppc64
Building for target ppc64
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.64666
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf diskdumputils-1.1.9
+ /bin/gzip -dc /usr/src/redhat/SOURCES/diskdumputils-1.1.9.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd diskdumputils-1.1.9
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.64666
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd diskdumputils-1.1.9
+ LANG=C
+ export LANG
+ unset DISPLAY
+ make
ln -sf ppc64 arch
echo "#define CMD_VERSION \"1.1.9\"" > version.h
cc -g -O -Wall `pkg-config --cflags glib-2.0` -Wall -D_FILE_OFFSET_BITS=64 -m64   -c -o diskdumpctl_proc.o diskdumpctl_proc.c
cc -g -O -Wall `pkg-config --cflags glib-2.0` -Wall -D_FILE_OFFSET_BITS=64 -m64   -c -o diskdumpcmn.o diskdumpcmn.c
cc -o diskdumpctl_proc diskdumpctl_proc.o diskdumpcmn.o -m64 -L/usr/lib64 -lglib-2.0
/usr/bin/ld: skipping incompatible /usr/lib/gcc/ppc64-redhat-linux/3.4.4/../../../libglib-2.0.so when searching for -lglib-2.0
/usr/bin/ld: skipping incompatible /usr/lib/gcc/ppc64-redhat-linux/3.4.4/../../../libglib-2.0.a when searching for -lglib-2.0
/usr/bin/ld: skipping incompatible /usr/lib/libglib-2.0.so when searching for -lglib-2.0
/usr/bin/ld: skipping incompatible /usr/lib/libglib-2.0.a when searching for -lglib-2.0
/usr/bin/ld: cannot find -lglib-2.0
collect2: ld returned 1 exit status
make: *** [diskdumpctl_proc] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.64666 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.64666 (%build)


Version-Release number of selected component (if applicable):
diskdumputils-1.1.9-4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
  

Additional info:

Comment 1 Dave Anderson 2005-09-13 19:56:04 UTC
Akira,

I've re-assigned this "diskdumputils" component Bugzilla to you as always.

However it's not clear to me how it can be considered a "diskdumputils"
component, i.e., what can be done to the diskdumputils user package
to address what appears to be a ppc/ppc64 packaging issue?


Comment 2 Bill Nottingham 2005-09-13 20:16:55 UTC
Not a bug, really. Not all ppc64 devel libs are included.

Comment 5 Akira Imamura 2007-07-25 20:08:54 UTC
I think this bugzilla can be closed as NOTABUG. May I close this?

Thanks,
Akira

Comment 6 Ben Levenson 2007-09-04 21:06:38 UTC
(In reply to comment #5)
> I think this bugzilla can be closed as NOTABUG. May I close this?

yes, thanks.


Note You need to log in before you can comment on or make changes to this bug.