Bug 16826 - "rpc.statd forgot to set AF_INET in udp sendmsg. Fix it!"
"rpc.statd forgot to set AF_INET in udp sendmsg. Fix it!"
Status: CLOSED DUPLICATE of bug 23176
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-23 17:22 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 17:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-08-23 17:22:05 EDT
I know that the lockd problem has been solved, don't know if the following 
kernel message (from net/ipv4/udp.c) is correlated (solved too) or not (to 
be solved):

I usually get
Aug 21 16:15:00 i5 nfslock: lockd shutdown failed
Aug 21 14:15:00 i5 rpc.statd[390]: Caught signal 15, un-registering and 
exiting.
Aug 21 16:15:01 i5 nfslock: rpc.statd shutdown succeeded

Today, just once, I've got
Aug 23 19:53:46 i5 nfslock: lockd shutdown failed
Aug 23 17:53:46 i5 rpc.statd[379]: Caught signal 15, un-registering and 
exiting.
Aug 23 19:53:46 i5 kernel: rpc.statd forgot to set AF_INET in udp sendmsg. 
Fix it!
Aug 23 19:53:46 i5 nfslock: rpc.statd shutdown succeeded

Also, what about rpc.statd logging using UTC timezone instead of CEST 
(mine)?
Comment 1 Pekka Savola 2000-12-19 17:38:46 EST
Wild guess: it's running in chroot jail but there is no /etc/localtime.
Comment 2 giulioo 2001-01-15 17:38:04 EST

*** This bug has been marked as a duplicate of 23176 ***

Note You need to log in before you can comment on or make changes to this bug.