Bug 168307 - "free(): Invalid pointer 0x..." error during start up
"free(): Invalid pointer 0x..." error during start up
Status: CLOSED DUPLICATE of bug 165033
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2005-09-14 15:24 EDT by De-Wei Yin
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-14 15:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description De-Wei Yin 2005-09-14 15:24:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Red Hat/1.7.10-

Description of problem:
System has initscripts-7.31.26.EL-1, hotplug-2002_04_01-20.5, and kernel-2.4.21-32.0.1.EL or kernel-2.4.21-35.EL installed.  During system start up (booting either kernel listed above), the messages "free(): Invalid pointer 0x..." is displayed right after "Press 'I' to enter interactive startup."

System with initscripts-7.31.22.EL-2 and hotplug-2002_04_01-20.4 does not display this message.

Version-Release number of selected component (if applicable):
initscripts-7.31.26.EL-1, hotplug-2002_04_01-20.5

How reproducible:

Steps to Reproduce:
1. Install RHEL WS or AS from installation CDs (downloaded ISO images).
2. Enable RHN updates and subscribe to the beta channels for RHEL.
3. Update initscripts and hotplug from the beta channel.
4. Reboot and watch the console messages carefully.

Actual Results:  With initscripts-7.31.26.EL-1, hotplug-2002_04_01-20.5 from the RHEL 3 beta channel installed, get the "free(): Invalid pointer 0x..." message during start-up.

With initscripts-7.31.22.EL-2 and hotplug-2002_04_01-20.4 from the stable RHEL 3 release, there is no error message.

The kernel package does not appear to matter (tried both kernel-2.4.21-32.0.1.EL and kernel-2.4.21-35.EL, the i686 version on Pentium 4 machines and the SMP version on a dual Athlon machine).

Despite the error, the system will continue the start-up process, and appears to run normally.

Expected Results:  No "free(): Invalid pointer 0x..." message.

Additional info:
Comment 1 Bill Nottingham 2005-09-14 15:35:43 EDT

*** This bug has been marked as a duplicate of 165033 ***

Note You need to log in before you can comment on or make changes to this bug.