Bug 168308 - Openoffice draw crash (unknown cause)
Openoffice draw crash (unknown cause)
Status: CLOSED DUPLICATE of bug 167130
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 15:39 EDT by Jim Snow
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 04:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Snow 2005-09-14 15:39:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I had several drawings open in OOo draw.  I don't know what I could have done to trigger the crash (I wasn't actively editing the drawings at the time), but a window popped up saying:

OOo has crashed!: Paste this text into your bugreport

0x479b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x47a3e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0xa74420:  + 0x420 (__kernel_sigreturn + 0x0)
0xb492e19c: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x18319c
0x13fd0ea: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960ea
0x13fad80: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x193d80 (SfxDispatcher::_FillState(SfxSlotServer const&, SfxItemSet&, SfxSlot const*) + 0x54)
0x1407034: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0034
0x1407288: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0288
0x1407432: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0432
0x3dcf5a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x825a2
0x3ddb13e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e13e (Timer::Timeout() + 0x10)
0x3ddb4b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e4b8
0x307cfe5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efe5
0x307cfd0: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efd0 (SalData::Timeout() const + 0x24)
0x6a4352: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa352
0x7b64f06: /usr/lib/libglib-2.0.so.0 + 0x24f06
0x7b633ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0x7b663f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0x7b668d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0x6a4535: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa535
0x3083da1: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45da1 (X11SalInstance::Yield(unsigned char) + 0x29)
0x3dd591c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8891c (Application::Yield() + 0x50)
0x3dd595a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8895a (Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670 (desktop::Desktop::Main() + 0x149a)
0x3ddad49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dd49 (SVMain() + 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main + 0x47)
0x7cbde6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659 (Window::RequestHelp(HelpEvent const&) + 0x31)


Version-Release number of selected component (if applicable):
openoffice.org-draw-1.9.117-3.1.0.fc4

How reproducible:
Didn't try


Additional info:
Comment 1 Caolan McNamara 2005-09-15 04:22:10 EDT
Yeah, saw a report like that before, hard to be sure as it's so intermittent,
but it will be backported to fc4 soon. You should probably update to the latest
fc4-update 1.9.125 in the interim.

*** This bug has been marked as a duplicate of 167130 ***

Note You need to log in before you can comment on or make changes to this bug.