Bug 168338 - Created installer fail after Required Install Media
Created installer fail after Required Install Media
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 168396 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 01:25 EDT by Gilles J. Seguin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 08:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iw/progress_gui.py patch (465 bytes, patch)
2005-09-15 01:32 EDT, Gilles J. Seguin
no flags Details | Diff
anaconda.spec.diff patch (885 bytes, patch)
2005-09-15 01:40 EDT, Gilles J. Seguin
no flags Details | Diff

  None (edit)
Description Gilles J. Seguin 2005-09-15 01:25:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.5.2

Description of problem:
Have created Installed discs with current updated version of gtk2.
We go through the process to install FC4-updated
using graphical install option.
That means, the text install already succeed without provided patch.

Steps to reproduce.
After the information dialog telling you the required discs.
The installation terminate with following information.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 876, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1198, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/progress_gui.py", line 335, in getScreen
    progressTable.attach (self.totalProgress, 1, 2, 0, 1, ypadding=2)
TypeError: GtkTable.attach() argument 8, item 14711675, item 2271359, item 383,

David Woodhouse has given hint on the fedora mailing about this problem.
I have ask him to provide a patch.

The patch was having the following lines, tell us that it is a backport.
--- iw/progress_gui.py.yy       2005-05-23 16:11:06.000000000 -0400
+++ iw/progress_gui.py  2005-09-13 02:45:36.000000000 -0400

cvs access has confirm presence of the change.

After rebuilding the installation with the patched anaconda package.
The graphical installation has completed successfully.

i have included the patch has attachment

thanks to David,


Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. see Description above
2.
3.
  

Actual Results:  see Description above


Additional info:
Comment 1 Gilles J. Seguin 2005-09-15 01:32:51 EDT
Created attachment 118832 [details]
iw/progress_gui.py patch

patch for iw/progress_gui.py in anaconda-10.2.1.5-2
Comment 2 Gilles J. Seguin 2005-09-15 01:40:44 EDT
Created attachment 118833 [details]
anaconda.spec.diff patch

warning: Release has not been increase.

Thoses are the change to the spec file used during my test.
Provided for completness.
Comment 3 Jeremy Katz 2005-09-15 08:54:29 EDT
Rebuilding the installer like this isn't really supported.  Also, note that this
is really a pygtk2 bug that is fixed in the newest pygtk2 update.
Comment 4 Gilles J. Seguin 2005-09-16 10:57:05 EDT
*** Bug 168396 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.