Bug 168342 - Wrong mime types for certificates and revokation lists
Wrong mime types for certificates and revokation lists
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 03:01 EDT by Peio Popov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 08:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peio Popov 2005-09-15 03:01:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
mod_ssl adds two new mime types in /etc/httpd/conf.d/ssl.conf 
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl    .crl

Accordind to rfc2585 (http://www.faqs.org/rfcs/rfc2585.html) the correct records should be:
AddType application/pkix-cert .crt
AddType application/pkix-crl  .crl 

Both mime types are included in /etc/mime.types but they have no files associated with them.

Version-Release number of selected component (if applicable):
mod_ssl-2.0.46 

How reproducible:
Always

Steps to Reproduce:
It is a configuration issue.

Additional info:
Comment 1 Joe Orton 2005-09-15 07:50:54 EDT
Thanks for the report.

The problem is that Mozilla/Firefox recognize the legacy x-* MIME types and will
prompt the user to import the cert/CRL into the user profile.   They do *not*
recognize the pkix-* types, unfortunately.  So changing this in a RHEL3 update
would cause a compatibility issue.
Comment 2 Joe Orton 2007-04-25 08:22:40 EDT
Per above comment - since the default types used must be compatible with
Mozilla/Firefox, these cannot be changed.

Note You need to log in before you can comment on or make changes to this bug.