Bug 168354 - openoffice.org won't start due to the missing libicui18n.so.34
openoffice.org won't start due to the missing libicui18n.so.34
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 06:29 EDT by Luya Tshimbalanga
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 14:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2005-09-15 06:29:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
When I click any openoffice.org application, it won't start at all after update.

Version-Release number of selected component (if applicable):
openoffice.org-1.9.129-2.2.fc5

How reproducible:
Always

Steps to Reproduce:
1. Simply start any openoffice.org application
2.
3.
  

Actual Results:  openoffice.org won't start due to the missing libicui18n.so.34.

/usr/lib/openoffice.org2.0/program/swriter.bin: error while loading shared libraries: libicui18n.so.34: cannot open shared object file: No such file or directory


Expected Results:  openoffice.org application should be loaded

Additional info:
Comment 1 Caolan McNamara 2005-09-15 06:44:23 EDT
how did you manage to install the rpm without resolving the icu dependancy at
rpm installation stage ?

i.e.

rpm -qRp openoffice.org-core-1.9.129-2.2.fc5.i386.rpm | grep icu
shows...

libicui18n.so.34
libicule.so.34
libicuuc.so.34

so it shouldn't have installed unless libicui18n.so.34 was available. Using yum
should have pulled in the libicu requirement.

what does

> rpm -q libicu say ?
Comment 2 Luya Tshimbalanga 2005-09-15 14:55:06 EDT
I have used pup for updating openoffice.org. I found out pup was broken which
problably explains why libicu could not be found.

Using "rpm -q libicu" will say that that package is not installed. I have no
idea how yum managed to remove libici because previous
openoffice.org-core-1.9.127 worked like charm.

Now that the problem is found, I guess I can peacefully set that bug as solved.

Note You need to log in before you can comment on or make changes to this bug.