Bug 168389 - Bogus value of EBP in asm-x86-64/ptrace.h
Bogus value of EBP in asm-x86-64/ptrace.h
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-09-15 12:11 EDT by Jeff Dike
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-22 14:14:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Dike 2005-09-15 12:11:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
diff -u /usr/include/asm-x86_64/ptrace.h include/asm-x86_64/ptrace.h 
--- /usr/include/asm-x86_64/ptrace.h    2003-06-28 06:03:47.000000000 -0400
+++ include/asm-x86_64/ptrace.h 2005-09-01 14:29:05.000000000 -0400
@@ -6,7 +6,7 @@
 #define R14 8
 #define R13 16
 #define R12 24
-#define RBP 36
+#define RBP 32
 #define RBX 40

/usr/include/asm-x86_64/ptrace.h is FC4
include/asm-x86_64/ptrace.h is 2.6.14-rc1

RBP == 36 makes no sense, as it's not divisible by 8

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Examine ptrace.h

Additional info:
Comment 1 Christian Iseli 2007-01-22 06:04:06 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 2 Jeff Dike 2007-01-22 14:14:08 EST
Fixed in FC6.

Note You need to log in before you can comment on or make changes to this bug.