Bug 168396 - Created installer fail after Required Install Media
Created installer fail after Required Install Media
Status: CLOSED DUPLICATE of bug 168338
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 13:53 EDT by Gilles J. Seguin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 14:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iw/progress_gui.py patch (465 bytes, patch)
2005-09-15 14:04 EDT, Gilles J. Seguin
no flags Details | Diff

  None (edit)
Description Gilles J. Seguin 2005-09-15 13:53:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.5.2

Description of problem:
Have created Installed discs with current updated version of gtk2.
We go through the process to install FC4-updated
using graphical install option.
That means, the text install already succeed without provided patch.

Steps to reproduce.
After the information dialog telling you the required discs.
The installation terminate with following information.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 876, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1198, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/progress_gui.py", line 335, in getScreen
    progressTable.attach (self.totalProgress, 1, 2, 0, 1, ypadding=2)
TypeError: GtkTable.attach() argument 8, item 14711675, item 2271359, item 383,

David Woodhouse has given hint on the fedora mailing about this problem.
I have ask him to provide a patch.

The patch was having the following lines, tell us that it is a backport.
--- iw/progress_gui.py.yy       2005-05-23 16:11:06.000000000 -0400
+++ iw/progress_gui.py  2005-09-13 02:45:36.000000000 -0400

cvs access has confirm presence of the change.

After rebuilding the installation with the patched anaconda package.
The graphical installation has completed successfully.

i have included the patch has attachment

thanks to David,


Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. see Description above
2.
3.
  

Actual Results:  see Description above


Additional info:
Comment 1 Gilles J. Seguin 2005-09-15 14:04:42 EDT
Created attachment 118863 [details]
iw/progress_gui.py patch

iw/progress_gui.py patch
Comment 2 Jeremy Katz 2005-09-15 14:06:49 EDT
Anaconda in FC4 is fine with what shipped _in FC4_.  We don't support rebuilt
trees for reasons just like this.  It's actually a pygtk2 bug that's fixed in
later pygtk2.
Comment 3 Gilles J. Seguin 2005-09-15 14:51:45 EDT
(In reply to comment #2)

my guest here is that the bug was present before
pygtk2-2.6.2-0.fc4.4.i386.rpm
means, i can not confirm the faulty version.

I comment only to help localize version with the bad behavior.
the traceback must be enough clear to know if your is a bad one.
Comment 4 Gilles J. Seguin 2005-09-16 10:57:00 EDT

*** This bug has been marked as a duplicate of 168338 ***

Note You need to log in before you can comment on or make changes to this bug.