Bug 168408 - OpenOffice crashes at launch
OpenOffice crashes at launch
Status: CLOSED DUPLICATE of bug 168404
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 15:45 EDT by Tim Clemons
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 17:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clemons 2005-09-15 15:45:32 EDT
Description of problem:

On attempting to launch openoffice the application crashes just after the
splashscreen appears.  

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.125-1.1.0.fc4

How reproducible:
Every time.

Steps to Reproduce:
1. Launch OpenOffice.
2. Application crashes
  
Additional info:

Here's a backtrace from running /usr/lib/openoffice.org2.0/program/soffice.bin
within gdb:

#0  0x00734402 in __kernel_vsyscall ()
#1  0x00798118 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:67
#2  0x00799888 in *__GI_abort () at ../sysdeps/generic/abort.c:88
#3  0x005bfd18 in __gnu_cxx::__verbose_terminate_handler () from
/usr/lib/libstdc++.so.6
#4  0x005bda31 in __gxx_personality_v0 () from /usr/lib/libstdc++.so.6
#5  0x005bda66 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0x005bdbf4 in __cxa_rethrow () from /usr/lib/libstdc++.so.6
#7  0x005bfce9 in __gnu_cxx::__verbose_terminate_handler () from
/usr/lib/libstdc++.so.6
#8  0x005bda31 in __gxx_personality_v0 () from /usr/lib/libstdc++.so.6
#9  0x005bda66 in std::terminate () from /usr/lib/libstdc++.so.6
#10 0x005bdb9a in __cxa_throw () from /usr/lib/libstdc++.so.6
#11 0x0193db03 in ?? () from /usr/lib/openoffice.org2.0/program/libgcc3_uno.so
#12 0x0193f8ab in ?? () from /usr/lib/openoffice.org2.0/program/libgcc3_uno.so
#13 0x0193fc32 in ?? () from /usr/lib/openoffice.org2.0/program/libgcc3_uno.so
#14 0x019406be in ?? () from /usr/lib/openoffice.org2.0/program/libgcc3_uno.so
#15 0x006ac512 in cppu::throwException ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#16 0x004d2860 in ucbhelper::cancelCommandExecution ()
   from /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so
#17 0x01b3957e in component_getFactory () from
/usr/lib/openoffice.org2.0/program/libucpfile1.so
#18 0x01b2b5d6 in component_getFactory () from
/usr/lib/openoffice.org2.0/program/libucpfile1.so
#19 0x01b17fc5 in component_getFactory () from
/usr/lib/openoffice.org2.0/program/libucpfile1.so
#20 0x01b1ad73 in component_getFactory () from
/usr/lib/openoffice.org2.0/program/libucpfile1.so
#21 0x004a877c in ucb::Content::Content$base ()
   from /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so
#22 0x004a96b7 in ucb::Content::executeCommand ()
   from /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so
#23 0x0045c0ab in utl::UcbLockBytes::setStream_Impl ()
   from /usr/lib/openoffice.org2.0/program/libutl680li.so
#24 0x0045d7bc in utl::UcbLockBytes::CreateLockBytes ()
   from /usr/lib/openoffice.org2.0/program/libutl680li.so
#25 0x00466b4c in utl::UcbStreamHelper::CreateStream ()
   from /usr/lib/openoffice.org2.0/program/libutl680li.so
#26 0x00466ded in utl::UcbStreamHelper::CreateStream ()
   from /usr/lib/openoffice.org2.0/program/libutl680li.so
#27 0x05ac2744 in SfxApplication::RegisterInterface ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#28 0x05bb6374 in SfxDispatcher::~SfxDispatcher ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#29 0x05bb64e7 in SfxDispatcher::SfxDispatcher ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#30 0x05abfe51 in SfxApplication::LoadTemplate ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#31 0x05accafd in SfxApplication::SetApp ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#32 0x05acce16 in SfxApplication::GetOrCreate ()
   from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#33 0x05aa999e in GetImage () from /usr/lib/openoffice.org2.0/program/libsfx680li.so
#34 0x05bced31 in non-virtual thunk to
SfxStatusListener::queryInterface(com::sun::star::uno::Type const&) () from
/usr/lib/openoffice.org2.0/program/libsfx680li.so
#35 0x05bceea5 in non-virtual thunk to
SfxStatusListener::queryInterface(com::sun::star::uno::Type const&) () from
/usr/lib/openoffice.org2.0/program/libsfx680li.so
#36 0x006bd94f in cppu::createStandardClassWithSequence ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#37 0x006bd20b in cppu::createStandardClassWithSequence ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#38 0x006bd272 in cppu::createStandardClassWithSequence ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#39 0x006bed1f in cppu::createFactoryProxy ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#40 0x006bd20b in cppu::createStandardClassWithSequence ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#41 0x006bd2c3 in cppu::createStandardClassWithSequence ()
   from /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3
#42 0x04e66515 in component_getFactory ()
   from /usr/lib/openoffice.org2.0/program/servicemgr.uno.so
#43 0x04e62ee7 in component_getFactory ()
   from /usr/lib/openoffice.org2.0/program/servicemgr.uno.so
#44 0x009139d7 in desktop::Desktop::Main () from
/usr/lib/openoffice.org2.0/program/libsoffice.so
#45 0x00196b41 in SVMain () from /usr/lib/openoffice.org2.0/program/libvcl680li.so
#46 0x0090f6c7 in sal_main () from /usr/lib/openoffice.org2.0/program/libsoffice.so
#47 0x00784d5f in __libc_start_main (main=0x8048474, argc=1, ubp_av=0xbf9cb414,
    init=0x8048548 <__libc_csu_init>, fini=0x8048598 <__libc_csu_fini>,
    rtld_fini=0x7601ad <_dl_fini>, stack_end=0xbf9cb40c) at
../sysdeps/generic/libc-start.c:216
#48 0x080484c5 in _start ()
Comment 1 Caolan McNamara 2005-09-15 17:31:24 EDT

*** This bug has been marked as a duplicate of 168404 ***

Note You need to log in before you can comment on or make changes to this bug.