Bug 168423 - Installer crashes on partition modifications during reinstall
Installer crashes on partition modifications during reinstall
Status: CLOSED DUPLICATE of bug 168286
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 16:59 EDT by Kent Olsen
Modified: 2013-01-09 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 20:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (882.43 KB, text/plain)
2005-10-12 16:38 EDT, Peter Ennis
no flags Details

  None (edit)
Description Kent Olsen 2005-09-15 16:59:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The installer crashed after manually defining the disk environment, prior to formatting the drives.  The error message is "Error informing the kernel about modifications to partition /dev/sdb10 - device or resource busy".

Key items to note:

- Dell Dimension 4700 desktop.
- Win/XP installed on primary SATA drive.
- Fedora installed onto second 300GB SATA drive (using entire drive).

The previous install of Fedora on this drive aborted approximately 1/2 way through disc1 with a media error.


Last two lines of trace are:

File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems diskset.savePartitions()
File "/usr/lib/anaconda/partedUtils.py", line 726, in saveParitions disk.commit()



Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:

The problem is not reproducible.  Reinstalling Fedora went smoothly.

Additional info:
Comment 1 Peter Ennis 2005-10-12 16:38:05 EDT
Created attachment 119852 [details]
anaconda dump
Comment 2 Peter Ennis 2005-10-12 16:42:55 EDT
The anaconda dump is from a
Gateway FLEXATXSTC Bro Essential 733C.
FC4 dies on changing partitions.
The error can be ignored, but when I did this
and continued then grub failed with the
famous "Error 28: Selected item cannot fit into memory"

PFE
----------------
    
Comment 3 Peter Ennis 2005-10-12 18:45:34 EDT
Reinstall
Choose Auto partitioning
Cancel when it errors
Reboot and install and it will reformat the drive
FC4 install completes
Boots fine with no errors.

On to updating ...

PFE
Comment 4 Majid 2005-11-07 07:12:31 EST
I have nearly same problem. The install process hangs on (with same error
message), and when I manually mount the partition, I have : 

No such device or address

Hardware : 
motherboard --> GA-8IPE775-PRO
network card -> 3Com Corporation 3c905C-TX/TX-M
hard disk   --> Seagate barracuda 7200.7

Additionnal info :
- we have 2 pools of computers (2 different hardware sets). With one,
installation performs perfectly.
- we perform a network installation
Comment 5 Jesse Keating 2006-01-23 20:17:32 EST
(In reply to comment #4)
> I have nearly same problem. The install process hangs on (with same error
> message), and when I manually mount the partition, I have : 
> 
> No such device or address
> 
> Hardware : 
> motherboard --> GA-8IPE775-PRO
> network card -> 3Com Corporation 3c905C-TX/TX-M
> hard disk   --> Seagate barracuda 7200.7
> 
> Additionnal info :
> - we have 2 pools of computers (2 different hardware sets). With one,
> installation performs perfectly.
> - we perform a network installation

Can you retry after blanking the disk, following the instructions given in bug
168286.  Marking as duplicate.

*** This bug has been marked as a duplicate of 168286 ***
Comment 6 Majid 2006-01-29 05:51:35 EST
Sorry, we passed round this bug, by images deployement (via Partimage and a
self- made initrd).

Do you want we test this, though ?
Comment 7 Jesse Keating 2006-01-29 12:31:30 EST
please.  You or the original filer.

Note You need to log in before you can comment on or make changes to this bug.