Bug 168456 - Uninstall failes (%preun scriptlet)
Uninstall failes (%preun scriptlet)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: athcool (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dawid Gajownik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 05:35 EDT by Christian Nolte
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 14:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file to build an RPM which installs athcool as a service (2.72 KB, text/plain)
2005-09-16 05:35 EDT, Christian Nolte
no flags Details
Patch to remove the warning message, used by the previously added SPEC-File (333 bytes, patch)
2005-09-16 05:36 EDT, Christian Nolte
no flags Details | Diff

  None (edit)
Description Christian Nolte 2005-09-16 05:35:01 EDT
Description of problem:

Removal of athcool rpm fails.

Version-Release number of selected component (if applicable):

athcool-0.3.11-2.fc4

How reproducible:

rpm -ev athcool-0.3.11-2.fc4

Actual results:

Error: %preun(athcool-0.3.11-2.fc4.i386) scriptlet failed, exit status 1

Expected results:

It should uninstall

Additional info:

Uninstallation works using this command line:

rpm -ev athcool-0.3.11-2.fc4 --nopreun

Attached you'll find my spec-file which I created for athcool. I use it several
month on different machines. It installs athcool additionally as a service under
fc4. Feel free to modify and use it!
Comment 1 Christian Nolte 2005-09-16 05:35:01 EDT
Created attachment 118886 [details]
SPEC file to build an RPM which installs athcool as a service
Comment 2 Christian Nolte 2005-09-16 05:36:48 EDT
Created attachment 118887 [details]
Patch to remove the warning message, used by the previously added SPEC-File
Comment 3 Dawid Gajownik 2005-09-16 10:53:03 EDT
Hi!

Thanks for the feedback. Nice to know that someone else is using this software ;-)

Can you tell me what shows you this command:

rpm -V athcool

Have you upgraded your version of athcool with one from Fedora Extras? Can you
test a fresh install of athcool? I'm not able to reproduce this bug

[root@X ~]# rpm -ev athcool
[root@X ~]#

I used scriptlets form this document →
http://fedoraproject.org/wiki/ScriptletSnippets and they should work without a
glitch ;)
Comment 4 Dawid Gajownik 2006-02-24 14:32:54 EST
As I said before, I cannot reproduce this bug here. You did not answer to my
questions so I'm closing as CANTFIX. Feel free to reopen this bug report...

Note You need to log in before you can comment on or make changes to this bug.