Bug 168469 - logwatch needs improvements for up2date parsing
logwatch needs improvements for up2date parsing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logwatch (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
: FutureFeature
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2005-09-16 11:08 EDT by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0333
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 17:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch. (845 bytes, patch)
2005-09-19 04:16 EDT, Ivana Varekova
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2005-09-16 11:08:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
logwatch should be extended for better parsing up2date log file

Version-Release number of selected component (if applicable):
logwatch-4.3.2-2

How reproducible:
Always

Steps to Reproduce:
1. create some up2date error conditions
2. take a look at logwatch output

  

Actual Results:  Some examples:

missing reason:

 --------------------- up2date Begin ------------------------ 
**Unmatched Entries**
Error communicating with server. The message was:
 ---------------------- up2date End ------------------------- 

Caused by:

[Thu Sep 15 04:02:04 2005] up2date updating login info
[Thu Sep 15 04:02:04 2005] up2date logging into up2date server
[Thu Sep 15 04:02:04 2005] up2date A socket error occurred: (111, 'Connection refused'), attempt #1
[Thu Sep 15 04:02:09 2005] up2date A socket error occurred: (111, 'Connection refused'), attempt #2
[Thu Sep 15 04:02:14 2005] up2date A socket error occurred: (111, 'Connection refused'), attempt #3
[Thu Sep 15 04:02:19 2005] up2date A socket error occurred: (111, 'Connection refused'), attempt #4
[Thu Sep 15 04:02:24 2005] up2date A socket error occurred: (111, 'Connection refused'), attempt #5
[Thu Sep 15 04:02:24 2005] up2date Error communicating with server. The message was:
Connection refused

-> note that here it looks like that up2date (up2date-4.2.57-2) logging can be improved also


Displaying unneccessary contents:
 
 --------------------- up2date Begin ------------------------ 
 **Unmatched Entries**
 Updating package profile
 Updating package profile
 ---------------------- up2date End ------------------------- 

Caused by:

[Fri Sep 16 11:56:54 2005] up2date Updating package profile
[Fri Sep 16 11:56:57 2005] up2date Updating package profile


Expected Results:  Better support of up2date log file

Additional info:
Comment 1 Ivana Varekova 2005-09-19 04:16:58 EDT
Created attachment 118962 [details]
Proposed patch.

Hello,
thank you for your notice. The attached patch fixes these two problems. Could
you please test this patch, and attach message if the results are right or if
there is any problem with up2date logwatch output.
Comment 2 Peter Bieringer 2005-09-19 17:04:38 EDT
Looks like working for at least "Updating package profile"

BTW: this problem occurs at leastup to version logwatch-6.0.1-4, so the version
of RHEL4 should also be fixed.
Comment 11 Red Hat Bugzilla 2006-05-10 17:43:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0333.html

Note You need to log in before you can comment on or make changes to this bug.