Bug 168534 - crashed on push
crashed on push
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 17:32 EDT by Bill Nottingham
Modified: 2016-09-19 22:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 18:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-09-16 17:32:55 EDT
When pushing:
https://porkchop.devel.redhat.com/fedora-updates/push.py/multi_push?checked=xorg-x11-6.8.2-1.FC3.45+Final&checked=xorg-x11-6.8.2-37.FC4.48.1+Final&push=Push+Selected

It died after the sending mail part, with:


Updating/closing bug: 69335
74398
118773
133451
135233
142429
142744
150174
152608
Mod_python error: "PythonHandler mod_python.publisher" Traceback (most recent
call last): 
File
"/usr/src/build/513032-i386/install/usr/lib/python2.2/site-packages/mod_python/apache.py",
line 332, in HandlerDispatch
File
"/usr/src/build/513032-i386/install/usr/lib/python2.2/site-packages/mod_python/publisher.py",
line 199, in handler
File "/mnt/redhat/fedora-updates/push.py", line 519, in multi_push
          bugs.add_comment(bug, update['bugmsg'])
File "/mnt/redhat/fedora-updates/bugs.py", line 16, in add_comment
          server.bugzilla.addComment(bug, comment, login, password, 0)
File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
          return self.__send(self.__name, args)
File "/usr/lib/python2.2/xmlrpclib.py", line 975, in __request
          verbose=self.__verbose
File "/usr/lib/python2.2/xmlrpclib.py", line 853, in request
          return self.parse_response(h.getfile())
File "/usr/lib/python2.2/xmlrpclib.py", line 896, in parse_response
          return u.close()
File "/usr/lib/python2.2/xmlrpclib.py", line 571, in close
          raise apply(Fault, (), self._stack[0]) Fault:
Comment 1 Luke Macken 2005-09-16 18:17:38 EDT
It looks like it exploded when trying to comment on a private bug.  It now
catches any exceptions thrown in the bug comment/close function, and ignores them.

Note You need to log in before you can comment on or make changes to this bug.