Bug 168545 - tar error "Read 8704 bytes from -" when extracting from standard input in IDL install
tar error "Read 8704 bytes from -" when extracting from standard input in IDL...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
RHEL4U3NAK
:
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2005-09-16 19:21 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0336
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 17:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-09-16 19:21:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When extracting files from a tar file on standard input, an error message "tar: Read 8704 bytes from -" is written to standard error. The number is not always 8704. The message causes an error window to open up numerous times when installing IDL 6.1 on RHEL4. If the /bin/tar executable is replaced with one from RHEL3 there is no message and no problem. The problem happens every time for certain tar files, and not at all for certain other tar files. It seems to always happen if the tar file was created with "-b 1". It does not happen on RHEL3.

Version-Release number of selected component (if applicable):
tar-1.14-4

How reproducible:
Always

Steps to Reproduce:
1.echo hello >hello.txt
2.tar -b 1 -cf hello.tar hello.txt
3.cat hello.tar | tar xf -
  

Actual Results:  for step 3 above, this message on standard error:
tar: Read 2048 bytes from -

Expected Results:  no message

Additional info:

There is no error message if "-b 1" is used in the extract, as in:
cat hello.tar | tar -b 1 -xf -
The IDL 6.1 install script uses commands such as:
cat base1.tz | zcat | tar xf -
Since it is on CDROM, changing the script is non-trivial.
GNU tar 1.15.1 fixes a problem with extracting from standard input, but says the problem was introduced with 1.15, not 1.14.
ls -l /bin/tar: -rwxr-xr-x  1 root root 161380 Oct 11  2004 /bin/tar
Comment 1 Need Real Name 2005-09-16 19:45:41 EDT
One workaround: export TAR_OPTIONS=-b1
Comment 2 Peter Vrabec 2005-09-22 05:04:49 EDT
I think this message is not important, it has been already removed by upstream.
see(revision 1.83):
http://savannah.gnu.org/cgi-bin/viewcvs/tar/tar/src/buffer.c
http://savannah.gnu.org/cgi-bin/viewcvs/tar/tar/src/buffer.c.diff?r1=1.82&r2=1.83
Comment 11 Red Hat Bugzilla 2006-05-03 17:45:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0336.html

Note You need to log in before you can comment on or make changes to this bug.