Bug 168595 - yumex crashes afer adding plugin
Summary: yumex crashes afer adding plugin
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL: http://wiki.linux.duke.edu/WritingYum...
Whiteboard:
Keywords:
: 168594 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-17 19:17 UTC by Eli Wapniarski
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 19:08:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eli Wapniarski 2005-09-17 19:17:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
After adding the downloadonly plugin as described at     
http://wiki.linux.duke.edu/WritingYumPlugins and then running yumex without the -n    
switch yumex crashes (traceback to follow). Invoked with the -n switch then yumex runs   
but as soon as I try to update, the same traceback results.   
   

Version-Release number of selected component (if applicable):
yumex-0.42-5.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.  Enable the downloadonly plugin as described at  
http://wiki.linux.duke.edu/WritingYumPlugins 
2.  run yumex 
     

Actual Results:  yumex crashes 

Expected Results:  yumex should run just fine. 

Additional info:

Traceback (most recent call last):   
  File "/usr/share/yumex/yumex.py", line 864, in ?   
    mainApp = MainApplication()   
  File "/usr/share/yumex/yumex.py", line 81, in __init__   
    self.setup_yum()   
  File "/usr/share/yumex/yumex.py", line 836, in setup_yum   
    if self.yw.setup():   
  File "/usr/share/yumex/yumexClasses/yumbase.py", line 81, in setup   
    self.doPluginSetup()   
  File "__init__.py", line 157, in doPluginSetup   
  File "plugins.py", line 143, in __init__   
  File "plugins.py", line 159, in run   
  File "/etc/yum/pluginconf.d/downloadonly.py", line 7, in config_hook   
    parser.add_option('', '--downloadonly', dest='dlonly',   
AttributeError: 'NoneType' object has no attribute 'add_option'

Comment 1 Rahul Sundaram 2005-09-17 19:36:20 UTC
Thank you for the report. However this has been reported against the incorrect
component. Changing component from Fedora Core ->Yum to Fedora Extras -> Yumex.

Comment 2 Rahul Sundaram 2005-09-17 19:57:42 UTC
*** Bug 168594 has been marked as a duplicate of this bug. ***

Comment 3 Eli Wapniarski 2005-09-18 04:10:14 UTC
Ahh... OK (regarding the change from Fedora Core to Fedora Extras) Didn't see that. Thanks  

Comment 4 Tim Lauridsen 2005-10-04 07:27:02 UTC
I have not tested Yumex with yum plugins, i will look into this

Comment 5 Tim Lauridsen 2005-10-06 19:08:08 UTC
I have fixed the bug, i have disabled yum plugins when running yumex.
The fix will be included in next build. 0.42-06.

Comment 6 Eli Wapniarski 2005-10-07 06:36:51 UTC
Great, that yumex won't crash... However, will I be able to download only if need be. 

Comment 7 Tim Lauridsen 2005-10-08 16:28:31 UTC
The yum plugins is designed to be used with commandline yum, they will not work
the way they are supposed to i Yumex, because yumex uses the Yum API, in another
than the standard yum client. You can used alle the plugins you like in standard
yum, but in yumex they will not be initialized.


Comment 8 Eli Wapniarski 2005-10-08 19:06:24 UTC
K... and thanks. It seems to be working now. 

Comment 9 Tim Lauridsen 2005-10-09 07:05:22 UTC
If downloading only is at importend feature to you, i can put it on my yumex
todo list.

Comment 10 Eli Wapniarski 2005-10-09 08:31:19 UTC
It is an important feature when trying to install things like X, kde-libs, kde-base, qt, video driver. 
So if it can be worked in, that would be great. 
 
Eli 


Note You need to log in before you can comment on or make changes to this bug.