Bug 168609 - installing on Mac Mini causes monitor to go into power save mode
installing on Mac Mini causes monitor to go into power save mode
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-09-17 19:10 EDT by Edward Rudd
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-04 21:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Edward Rudd 2005-09-17 19:10:28 EDT
Description of problem:
Mac Mini purchased 1 weeks prior to 10.4 release. upgraded to 512MB ram. (40GB
HD, no wifi, no blue tooth, 1.25GHz).

Installing FC4 PPC (DVD iso) on the system causes the monitor to go into
powersave mode (DPMS off) and never restores.

I see yaboot load, I type linux <enter> and see the kernel load, and a video
switch to another FB mode, then another video switch which causes the the
monitor to go into power off mode. (Gateway EV700 17" monitor through apple
supplied DVI adapter)

I tried
linux resolution=1024x768
linux text

And the same thing occurs.  waiting does not yeild any change in the state of
the system.. I have to force off (holding power button for approx 10 seconds)
Comment 1 Edward Rudd 2005-09-17 19:21:27 EDT

Comment by websavages on 2005-06-01, 04:45 AM PDT

> when booting from cd to start the whole process the refresh rates used as 
> defaults were to high for my monitor (cheap) this was solved by appending
> video=ofonly to the boot prompt in yaboot
> linux video=ofonly resolution=1024x768

Adding video=ofonly resolved the issue.. What refresh rate is being *assumed*?
I know OS X shows a 60Hz and a 120Hz (which 120 causes my monitor to go "off" as
mentioned above).  but why would the higher be chosen over the slower?

I'll post DDCprobe information once the system gets up enough to get me a shell.
Comment 2 Dave Jones 2005-09-30 02:18:36 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Comment 3 Dave Jones 2005-11-10 14:16:55 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 4 Dave Jones 2006-02-03 01:39:13 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 5 John Thacker 2006-05-04 21:33:37 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.