Bug 168618 - amarok randomly crashes
amarok randomly crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 02:35 EDT by Jeff Pitman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 06:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (6.47 KB, text/plain)
2005-09-18 02:35 EDT, Jeff Pitman
no flags Details
Amarok 1.3.7 spec (12.07 KB, application/octet-stream)
2006-01-08 19:20 EST, Ilya Konstantinov
no flags Details

  None (edit)
Description Jeff Pitman 2005-09-18 02:35:36 EDT
Description of problem:  
  
Long running amarok process dumps core after deleting playlist and re-adding  
with another playlist. Must run "dynamic mode".  
  
Version-Release number of selected component (if applicable):  
  
[jeff@kubik ~]$ rpm -q amarok  
amarok-1.3.1-2.fc4  
  
  
Steps to Reproduce:  
[DISCLAIMER: Crashes are random, I cannot guarantee this will work.]  
  
1. Set dynamic mode to enabled.  
2. Inject new playlist.  
3. Listen to a couple of songs.  
4. Stop.  
5. Let Amarok run all night without doing a thing.  
6. Wake up.  
7. Clear list.  
8. Add new playlist.  
9. Crash.  
    
Actual results:  
  
Dead.  
  
Expected results:  
  
Living.  
  
Additional info:  
 
N/a
Comment 1 Jeff Pitman 2005-09-18 02:35:36 EDT
Created attachment 118942 [details]
backtrace
Comment 2 Aurelien Bompard 2005-09-18 12:12:47 EDT
I'm having a hard time reproducing this. I have the same setup, Amarok from
extras, and KDE from kde-redhat.
Which engine are you using ? Did you install the amarok-debuginfo rpm ?
Comment 3 Ilya Konstantinov 2006-01-08 19:18:58 EST
This was fixed in Amarok 1.3.7. I've trivially adapted the spec for Amarok 1.3.7
(and I'm running it right now).

Please note that taglib will have to be rebuilt as well, since it's built with
an old gcc.
Comment 4 Ilya Konstantinov 2006-01-08 19:20:04 EST
Created attachment 122933 [details]
Amarok 1.3.7 spec

Here's the spec I've used to build Amarok 1.3.7 RPM.
Comment 5 Aurelien Bompard 2006-01-09 04:09:33 EST
Amarok in Extras is already at version 1.3.7 :
http://download.fedora.redhat.com/pub/fedora/linux/extras/4/i386/amarok-1.3.7-1.fc4.i386.rpm

Do you still experience this problem ?
Comment 6 Ilya Konstantinov 2006-01-09 05:15:43 EST
Amarok is still at 1.3.6 in devel. Is this for a reason? (My note about taglib
needing rebuild too refers to devel)
Comment 7 Aurelien Bompard 2006-02-13 06:13:44 EST
Amarok will be upgraded to 1.4-beta in devel because rawhide is dropping
gstreamer 0.8 and only version 1.4 supports gst 0.10. I'll do this in the next days.
I'm closing this bug, feel free to reopen if version 1.3.8 still crashes randomly.

Note You need to log in before you can comment on or make changes to this bug.