Bug 168655 - Patch which fixes building as "python24".
Patch which fixes building as "python24".
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 01:52 EDT by jafo-redhat
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.1-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 10:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jafo-redhat 2005-09-19 01:52:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 StumbleUpon/1.999 Firefox/1.0.6

Description of problem:


Version-Release number of selected component (if applicable):
python-2.4.1-2

How reproducible:
Always

Steps to Reproduce:
1.Build Python RPM with "%define __python_ver 24"


Actual Results:  Dependency and other problems.

Expected Results:  Building of a clean set of "python24" packages.

Additional info:

Patch which fixes this:
Arguably, the second hunk might want to be %{python} instead of python%{pybasever}, but I'll leave that up to you.

Sean

*** python.spec 2005-09-18 23:36:29.136610000 -0600
--- /usr/src/redhat/SPECS/python.spec   2005-09-18 23:26:03.000000000 -0600
***************
*** 13,20 ****
  
  %define pybasever 2.4
  %define jp_codecs 1.4.11
! %define tools_dir %{_libdir}/python%{pybasever}/Tools
! %define demo_dir %{_libdir}/python%{pybasever}/Demo
  
  Summary: An interpreted, interactive, object-oriented programming language.
  Name: %{python}
--- 14,21 ----
  
  %define pybasever 2.4
  %define jp_codecs 1.4.11
! %define tools_dir %{_libdir}/python/Tools
! %define demo_dir %{_libdir}/python/Demo
  
  Summary: An interpreted, interactive, object-oriented programming language.
  Name: %{python}
***************
*** 105,111 ****
  Summary: A collection of development tools included with Python.
  Group: Development/Tools
  Requires: %{name} = %{version}-%{release}
! Requires: tkinter = %{version}-%{release}
  %if %{main_python}
  Obsoletes: python2-tools
  Provides: python2-tools = %{version}
--- 105,111 ----
  Summary: A collection of development tools included with Python.
  Group: Development/Tools
  Requires: %{name} = %{version}-%{release}
! Requires: %{tkinter} = %{version}-%{release}
  %if %{main_python}
  Obsoletes: python2-tools
  Provides: python2-tools = %{version}
***************
*** 259,264 ****
--- 260,266 ----
  mv pynche pynche%{__python_ver}
  mv pygettext.py pygettext%{__python_ver}.py
  mv msgfmt.py msgfmt%{__python_ver}.py
+ mv smtpd.py smtpd%{__python_ver}.py
  mv pydoc pydoc%{__python_ver}
  popd
  %endif
***************
*** 331,337 ****
  %doc Tools/pynche/README.pynche
  %{_libdir}/python%{pybasever}/site-packages/modulator
  %{_libdir}/python%{pybasever}/site-packages/pynche
! %{_bindir}/smtpd.py*
  %{_bindir}/idle*
  %{_bindir}/modulator*
  %{_bindir}/pynche*
--- 333,339 ----
  %doc Tools/pynche/README.pynche
  %{_libdir}/python%{pybasever}/site-packages/modulator
  %{_libdir}/python%{pybasever}/site-packages/pynche
! %{_bindir}/smtpd*.py*
  %{_bindir}/idle*
  %{_bindir}/modulator*
  %{_bindir}/pynche*
Comment 1 Mihai Ibanescu 2005-09-20 08:56:45 EDT
Not sure I understand yor comment - if you install python24, do you not want
tools_dir and demo_dir to be /usr/lib/python2.4/Tools and /Demo, respectively?
Why would they be living under /usr/lib/python? (this assumes a 32-bit system).

If you have both python = 2.4.1 and python24 = 2.4.1 then you will have
conflicts anyway. I must be missing something.
Comment 2 jafo-redhat 2005-09-20 09:09:37 EDT
The "%define __python_ver 24" exists so that you can use a Python 2.4 (or in the
future, 2.5) package on a system with a previous version of Python on it. 
However, the current packages are broken in that respect.

It looks like the first hunk of my patch is wrong, please ignore it.  Otherwise,
the patch should resolve the problems with defining __python_ver.

I'm not talking about installing both python=2.4.1 and python24=2.4.1.  Yes,
there would be conflicts in that instance, and there's really no need to build a
python24 in that instance.  However, on FCN where N<4 there is.

I'm the Python RPM maintainer for python.org, and was attempting to use these
RPMs for some Python.org packages when I ran into the problems above.  Of
course, on FC3 I also ran into a problem with the DB library version, but that's
not something that should be changed in your base package.  We are currently
working to fix the lib64 issue in the base Python release, but in the meantime
it looks like the Fedora packages are a good base set for me to use,
particularly for people running on systems with lib64.

So, in short, the __python_ver stuff in the Fedora package is not functional.

Sean
Comment 3 Mihai Ibanescu 2005-09-30 10:59:03 EDT
Patch should be incorporated in the latest Rawhide (2.4.1-11 or newer).

Note You need to log in before you can comment on or make changes to this bug.