Bug 168710 - Invalid HTML
Invalid HTML
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
: 224007 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 13:34 EDT by Alan Cox
Modified: 2013-06-23 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 13:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2005-09-19 13:34:39 EDT
The expert page contains invalid markup. This prevents elinks from using the
expert mode, and the other mode contains javascript so can't be used either
Comment 1 David Lawrence 2005-09-19 13:37:32 EDT
Will try to verify
Comment 2 Matěj Cepl 2007-04-02 11:03:05 EDT
Bugzilla contains so much broken HTML, that it is hard to believe it (take a
look at http://tinyurl.com/292p95 -- for example, didn't anybody tell to
Bugzilla authors, that id is supposed to be unique in one page --
http://www.w3.org/TR/1999/REC-html401-19991224/struct/global.html#adef-id ?). At
least when you are not able to produce valid XHTML 1.0 Strict, don't mark your
webpages as such!

This brokeness of web-pages makes it really difficult, if not almost impossible
to work around brokeness of BZ interface (or maybe just specific requirements of
this bugmaster) with Greasemonkey.
Comment 3 Matěj Cepl 2007-08-02 04:04:15 EDT
*** Bug 224007 has been marked as a duplicate of this bug. ***
Comment 4 David Lawrence 2008-09-16 12:53:35 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 5 Alan Cox 2008-09-16 13:21:56 EDT
Elinks bug filing now works.

Note You need to log in before you can comment on or make changes to this bug.