Bug 1687100 - On start Amarok reports "configured database plugin could not be loaded".
Summary: On start Amarok reports "configured database plugin could not be loaded".
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-09 19:17 UTC by David Koppelman
Modified: 2019-04-27 21:27 UTC (History)
6 users (show)

Fixed In Version: amarok-2.9.0-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-27 21:27:44 UTC
Type: Bug


Attachments (Terms of Use)

Description David Koppelman 2019-03-09 19:17:16 UTC
Description of problem:

When started Amarok pops up a dialog reporting a problem with the
database plugin:

    The amarok database reported the following errors:
    The configured database plugin could not be loaded.
    In most cases you will need to resolve these errors before Amarok will run properly.

The problem was encountered the first time Amarok was run after
upgrading to f30. There were no problems running Amarok in f29.


Version-Release number of selected component (if applicable):

amarok-2.9.0-3.fc30.x86_64    

How reproducible:

Every time.


Steps to Reproduce:
1. Start Amarok
2.
3.

Actual results:

Dialog reporting plugin problem.

Expected results:

Amarok UI.


Additional info:

Comment 1 David Koppelman 2019-03-10 23:46:31 UTC
Based on a perusal of some bug reports I suspect that the cause is a
build problem that prevents Amarok from loading plugins rather than a
problem with the database plugin. (I see errors for VLC and GStreamer
plugins in debug output obtained using the --debug switch.)

See https://bugs.gentoo.org/641060#c8

Comment 2 Fedora Update System 2019-04-22 21:37:49 UTC
amarok-2.9.0-4.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4aebf8bc56

Comment 3 Rex Dieter 2019-04-22 21:42:45 UTC
may also require rebuilt qt4 components from
https://bodhi.fedoraproject.org/updates/FEDORA-2019-399cb1caab

Comment 4 David Koppelman 2019-04-22 22:28:09 UTC
(In reply to Fedora Update System from comment #2)
> amarok-2.9.0-4.fc30 has been submitted as an update to Fedora 30.
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-4aebf8bc56

I tried this build and it works. That is, Amarok starts and runs correctly. Thank you!

Comment 5 Fedora Update System 2019-04-23 14:55:54 UTC
amarok-2.9.0-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4aebf8bc56

Comment 6 Fedora Update System 2019-04-27 21:27:44 UTC
amarok-2.9.0-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.