Bug 168742 - system-config-netboot prepared diskless client has issues with XKB config when running X
system-config-netboot prepared diskless client has issues with XKB config whe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Brich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 18:12 EDT by brian
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 0.1.33-1_EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 08:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brian 2005-09-19 18:12:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050909 Red Hat/1.0.6-1.4.2 Firefox/1.0.6

Description of problem:
After setting up a diskless image with system-config-netboot I am having issues with clients getting X up and running as expected.  Specifically as X is started via a run level 3 startx or after a login from the gui at run level 5 a window pops up stating "Error activating XKB configuration.  Probably internal X server problem.".  In an effort to correct this I have rerun system-config-display --noui on the client from run level 3 to insure the local personality of the diskless image is correct but the error window continues to pop up each time X is started.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create diskless image
2. boot to run level 3 or 5
3. startx or log into xdm
4. error window reporting XKB error pops up.
  

Additional info:
Comment 1 Jason Vas Dias 2005-09-19 19:53:01 EDT
I think I've found the cause of the problem here:
  /var/lib/xkb 
must be a snapshot directory, because on Xorg startup, it invokes 
'xkbcomp' to compile the keymap description .
When s-c-nb was first develeped XFree86 was in use, and this was not
an issue.
So, to fix:
  1. For each of your $NETBOO/snapshot/$client/ directories, create the
     /var/lib/xkb directory - this command should probably work:

     # for d in $NETBOOT/snapshot/*/var/lib; do mkdir $d/xkb; done

     (where $NETBOOT is the root location of your PXE OS, containing the 'root'
      directory where the OS is installed).

  2. Add /var/lib/xkb to $NETBOOT/snapshot/files.custom

  3. reboot your clients.

The next release will put /var/lib/xkb in the snapshot/files list .

  
Comment 2 Jason Vas Dias 2005-09-22 12:49:45 EDT
This bug is now fixed with system-config-netboot-0.1.33-1_EL4, which should be
in RHEL-4-U3. Meanwhile, you can download it from:
   http://people.redhat.com/~jvdias/system-config-netboot/RHEL-4 .

Note You need to log in before you can comment on or make changes to this bug.