Bug 168766 - savage driver 1.1.27mh hang
savage driver 1.1.27mh hang
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 168424
  Show dependency treegraph
 
Reported: 2005-09-20 03:22 EDT by Haruo Tomita
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0071
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:41:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program (974 bytes, application/x-gzip-compressed)
2005-09-20 03:50 EDT, Haruo Tomita
no flags Details
patch (7.66 KB, patch)
2005-09-20 03:54 EDT, Haruo Tomita
no flags Details | Diff
The patches were attached. (942 bytes, application/x-gzip-compressed)
2005-09-20 23:33 EDT, Haruo Tomita
no flags Details
The log was attached. (15.44 KB, application/x-gzip-compressed)
2005-09-20 23:34 EDT, Haruo Tomita
no flags Details

  None (edit)
Description Haruo Tomita 2005-09-20 03:22:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
Whenever this test program is executed, the system does hang. 


Version-Release number of selected component (if applicable):
XFree86-4.3.0-81.EL

How reproducible:
Always

Steps to Reproduce:
1. install drawline.tar.gz
2. execute drawline

  

Actual Results:  system is hung.

Expected Results:  Savage driver works. 

Additional info:
Comment 1 Haruo Tomita 2005-09-20 03:50:35 EDT
Created attachment 119015 [details]
test program
Comment 2 Haruo Tomita 2005-09-20 03:54:08 EDT
Created attachment 119016 [details]
patch
Comment 3 Haruo Tomita 2005-09-20 03:59:20 EDT
Issue of hang is corrected with this patch. 
Comment 4 Mike A. Harris 2005-09-20 04:17:42 EDT
Thanks for the report.  I've reviewed the patch, and have some questions:


Where did the patch originate?  It contains a number of changes which don't
actually do anything, ie:

-unsigned
+unsigned int

Curious if you got this from somewhere on the net, or from XFree86 or X.Org
CVS, or somewhere else?

+#if 0
 static void SavageSubsequentSolidTwoPointLine(


This will disable 2 point lines on all savage hardware.  Instead of this,
does using the XaaNoSolidTwoPointLine option with the stock Red Hat driver
yield the same result?

Some of the changes in the patch seem harmless, while other parts of the
patch touch code which is shared among different savage hardware, and of
which it is unclear as to the effect they might have on other Savage
hardware.

In addition to the above questions, please attach your X server log from
before and after this patch for review.

Thanks in advance.


Setting status to "NEEDINFO_REPORTER".  
Comment 5 Haruo Tomita 2005-09-20 04:38:10 EDT
This patch is not original. 
It is backported from savage driver 1.1.27 of RHEL4.
The cause of this issue is xaaptr->SolidBresenhamLineErrorTermBits = 14.
TermBit=14 will generate overfllow of the BCI command.
It should be xaaptr->SolidBresenhamLineErrorTermBits = 13.
I consented for the log. Please wait until tomorrow. 

Thanks.


 
Comment 6 Mike A. Harris 2005-09-20 17:36:23 EDT
Thanks.  We'll review the patch in greater depth, and do a risk analysis for
consideration in a future update.

Comment 7 Haruo Tomita 2005-09-20 23:24:03 EDT
(In reply to comment #6)
> Thanks.  We'll review the patch in greater depth, and do a risk analysis for
> consideration in a future update.

Thanks. Please contact me if there is an update. 
BTW, this isseu is solved with the following patches. 
(See attached file: patch.tar.gz)

diff -urN xc/programs/Xserver/hw/xfree86/drivers/savage.orig/savage_accel.c 
xc/programs/Xserver/hw/xfree86/drivers/savage/savage_accel.c
--- xc/programs/Xserver/hw/xfree86/drivers/savage.orig/savage_accel.c	2005-09-
20 17:41:38.000000000 +0900
+++ xc/programs/Xserver/hw/xfree86/drivers/savage/savage_accel.c	2005-09-
20 17:43:26.000000000 +0900
@@ -485,7 +485,7 @@
     xaaptr->SubsequentSolidFillTrap = SavageSubsequentSolidFillTrap; 
 #endif
 
-    xaaptr->SolidBresenhamLineErrorTermBits = 14;
+    xaaptr->SolidBresenhamLineErrorTermBits = 13;
 #endif
 
     /* ImageWrite */

 


Comment 8 Haruo Tomita 2005-09-20 23:33:31 EDT
Created attachment 119060 [details]
The patches were attached.
Comment 9 Haruo Tomita 2005-09-20 23:34:37 EDT
Created attachment 119061 [details]
The log was attached.
Comment 10 Mike A. Harris 2005-09-26 13:34:02 EDT
Thanks for the additional attachments.  We'll review this during RHEL3 U7
development for potential inclusion, and update the report again.

Comment 11 Mike A. Harris 2005-10-19 02:41:23 EDT
For future reference, when attaching patches or other text files, please attach
them as uncompressed file attachments of mime-type "text/plain" or check the
"patch" checkbox in bugzilla's file attachment feature.  This makes it easy to
review the patch inside the web browser directly, and speeds up our internal
processes.

I've reviewed both patches in the attachment in comment #8:

XFree86-4.3.0-savage-depth-24-made-colors-fix.patch:
  This one seems to be very obvious simple no-brainer fixes which appear
  to be correct and low risk.

XFree86-4.3.0-savage-bci-overflow-fix.patch:
  This one is non-obvious from the patch itself, without familiarity with
  the hardware/specs/driver code.  However, I have confirmed comment #5,
  and reviewed the current driver source as well, and the fix seems to
  be correct for this issue according to cvs commits et al.



Comment 19 Mike A. Harris 2005-11-28 15:46:01 EST
Patches applied to CVS for XFree86-4.3.0-98.EL
Comment 20 Mike A. Harris 2005-11-28 19:32:01 EST
XFree86-4.3.0-98.EL rpms built for RHEL3 U7 are temporarily available for
download and testing at the following URL:

    ftp://people.redhat.com/mharris/testing/3.0E

Please download a copy right away, even if you can't test them right away,
as I have limited disk quota, and the files will be removed to make space
for other things soon.

Setting status to "MODIFIED", and waiting for testing feedback from
bug reporter.
Comment 21 Haruo Tomita 2005-11-29 00:58:13 EST
XFree86-4.3.0-98.EL.src.rpm was downloaded. I begin testing. 
Comment 22 Mike A. Harris 2005-11-29 02:07:09 EST
Rebuilding the src.rpm can potentially introduce inconsistencies or anomalies
into the build which might not be present in our official buildsystem.
As such, it is preferred if possible that you the Red Hat generated
binaries are used for testing/confirmation, as they are what will
ultimately be released as official erratum.

Thanks for testing, and also for your fast response!
Comment 23 Haruo Tomita 2005-11-29 02:31:11 EST
> Rebuilding the src.rpm can potentially introduce inconsistencies or anomalies
> into the build which might not be present in our official buildsystem.
> As such, it is preferred if possible that you the Red Hat generated
> binaries are used for testing/confirmation, as they are what will
> ultimately be released as official erratum.
> Thanks for testing, and also for your fast response!

It has understood. 
An official binary of RHEL3 U7
The tester of Toshiba will confirm it by using international β. 

Thanks.
Comment 25 Haruo Tomita 2005-12-15 21:34:00 EST
I completed the test. XFree86-4.3.0-98.EL works well. 

Thanks.

Comment 26 Suzanne Hillman 2006-01-26 14:56:40 EST
Tested by reporter, moving to PASSES_QA.
Comment 28 Red Hat Bugzilla 2006-03-15 10:41:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0071.html

Note You need to log in before you can comment on or make changes to this bug.