Bug 168843 - compiler segfault when compiling redhat-crypt-md5.c from courier-authlib-0.55
compiler segfault when compiling redhat-crypt-md5.c from courier-authlib-0.55
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
http://pastebot.tceeg.com:8888/26
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 13:02 EDT by Nils Breunese
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 09:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source for redhat-crypt-md5.c (24.78 KB, text/plain)
2005-09-21 05:13 EDT, Nils Breunese
no flags Details

  None (edit)
Description Nils Breunese 2005-09-20 13:02:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; nl-nl) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
I'm following the qmailrocks.org installation guide to install a mail server. Step 12 (http://
www.qmailrocks.org/imap_rh.htm) involves building courier-authlib-0.55 but it always fails with a 
segmentation fault.

Version-Release number of selected component (if applicable):
gcc-3.4.4-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. Unpack the courier-authlib-0.55.tar.bz2 archive from qmailrocks.org 2.2.0
2. Configure it: ./configure --prefix=/usr/local --exec-prefix=/usr/local --with-authvchkpw --without-
authldap --without-authmysql --disable-root-check --with-ssl --with-authchangepwdir=/usr/local/
libexec/authlib --with-redhat
3. make && make check

Actual Results:  [snip]
Compiling redhat-crypt-md5.c
redhat-crypt-md5.c: In function `md5_crypt_redhat':
redhat-crypt-md5.c:126: internal compiler error: Segmentation fault
[snip]

Expected Results:  No compiler segfault.

Additional info:
Comment 1 Jakub Jelinek 2005-09-20 15:28:47 EDT
The compiler told you:
Preprocessed source stored into /tmp/cckqXU3R.out file, please attach this to
your bugreport.

Please do so.  Thanks.
Comment 2 Nils Breunese 2005-09-21 05:13:48 EDT
Created attachment 119068 [details]
Preprocessed source for redhat-crypt-md5.c
Comment 3 Jakub Jelinek 2005-09-21 15:35:13 EDT
Can't reproduce:

rpm -q gcc; gcc -S -g -O2 -Wall -fPIC 168843.i; echo $?
gcc-3.4.4-2.fc3
0

Note You need to log in before you can comment on or make changes to this bug.