Bug 16887 - Matshita scsi cdrom unexpected busfree
Matshita scsi cdrom unexpected busfree
Status: CLOSED DUPLICATE of bug 15110
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-24 14:00 EDT by Jón Fairbairn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-24 14:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2000-08-24 14:00:47 EDT
With kernel 2.2.5-15 cdrom works OK

With 2.2.16-3 when I try to mount the cdrom I get 
Aug 24 18:06:22 cryptogramme kernel: (scsi0:0:1:-1) Unexpected busfree,
LASTPHAS
E = 0x40, SEQADDR = 0x111 
Aug 24 18:06:36 cryptogramme kernel: (scsi0:0:1:-1) Unexpected busfree,
LASTPHAS
E = 0x40, SEQADDR = 0x110 
(repeated)

and mount doesn't return.  It also locks up the scsi bus for a few seconds
over and over. 

The system has scsi drives only, the controller is reported as
Aug 24 18:12:25 cryptogramme kernel: (scsi0) <Adaptec AHA-284X SCSI host
adapter> found at VLB slot 1 
Aug 24 18:12:25 cryptogramme kernel: (scsi0) Narrow Channel, SCSI ID=7,
4/255 SCBs 
Aug 24 18:12:25 cryptogramme kernel: (scsi0) Downloading sequencer code...
406 instructions downloaded 
Aug 24 18:12:25 cryptogramme kernel: scsi0 : Adaptec AHA274x/284x/294x
(EISA/VLB/PCI-Fast SCSI) 5.1.15/3.2.4 
Aug 24 18:12:25 cryptogramme kernel:        <Adaptec AHA-284X SCSI host
adapter> 
Aug 24 18:12:25 cryptogramme kernel: scsi : 1 host. 
Aug 24 18:12:25 cryptogramme kernel: (scsi0:0:0:0) Synchronous at 10.0
Mbyte/sec, offset 15. 
Aug 24 18:12:25 cryptogramme kernel:   Vendor: DEC       Model:
DSP3105S          Rev: 386C 
Aug 24 18:12:25 cryptogramme kernel:   Type:  
Direct-Access                      ANSI SCSI revision: 02 
Aug 24 18:12:25 cryptogramme kernel: Detected scsi disk sda at scsi0,
channel 0, id 0, lun 0 
Aug 24 18:12:25 cryptogramme kernel: (scsi0:0:1:0) Using asynchronous
transfers. 
Aug 24 18:12:25 cryptogramme kernel:   Vendor: MATSHITA  Model: CD-ROM
CR-503     Rev: 1.0f 
Aug 24 18:12:25 cryptogramme kernel:   Type:  
CD-ROM                             ANSI SCSI revision: 02 
Aug 24 18:12:25 cryptogramme kernel: Detected scsi CD-ROM sr0 at scsi0,
channel 0, id 1, lun 0 
Aug 24 18:12:25 cryptogramme kernel: (scsi0:0:2:0) Synchronous at 10.0
Mbyte/sec, offset 15. 
Aug 24 18:12:25 cryptogramme kernel:   Vendor: DEC       Model:
DSP3105S          Rev: 386C 
Aug 24 18:12:25 cryptogramme kernel:   Type:  
Direct-Access                      ANSI SCSI revision: 02 
Aug 24 18:12:25 cryptogramme kernel: Detected scsi disk sdb at scsi0,
channel 0, id 2, lun 0 
Aug 24 18:12:25 cryptogramme kernel: Uniform CDROM driver Revision: 2.54 

by 2.2.5-15
and (if I strip off the date info)
diff /tmp/scsi2.2.5-15 /tmp/scsi2.2.16-3 
3,4c3,4
<  (scsi0) Downloading sequencer code... 406 instructions downloaded 
<  scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.15/3.2.4 
---
>  (scsi0) Downloading sequencer code... 415 instructions downloaded 
>  scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.30/3.2.4 
11d10
<  (scsi0:0:1:0) Using asynchronous transfers. 
19c18
<  Uniform CDROM driver Revision: 2.54 
---
>  Uniform CD-ROM driver Revision: 3.10 


It's the aic7xxx scsi driver, and the problem occurs whether I use the rpm
of 2.2.16-3 (with aic7xxx loaded as a module) or compile it in.

At some point I had the line
optionsaic7xxx seltime=2 verbose=0xffff
in /etc/conf.modules, but the newer version rejects this.
Comment 1 Jón Fairbairn 2000-08-26 05:36:26 EDT
Same as bug 15110, as a less restrictive search would have told me (sorry).
Resolved by upgrading aic7xxx to 5.1.31

*** This bug has been marked as a duplicate of 15110 ***

Note You need to log in before you can comment on or make changes to this bug.