Bug 168883 - plugging in USB hard drive: /sbin/vol_id missing?
plugging in USB hard drive: /sbin/vol_id missing?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 17:44 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 03:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2005-09-20 17:44:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
Get the following messages when plugging in a USB hard drive.  Complaining about not finding /sbin/vol_id.

Sep 20 08:34:07 localhost kernel: usb 1-1: new high speed USB device
using ehci_hcd and address 7
Sep 20 08:34:07 localhost kernel: SCSI subsystem initialized
Sep 20 08:34:07 localhost kernel: Initializing USB Mass Storage driver...
Sep 20 08:34:07 localhost kernel: scsi0 : SCSI emulation for USB Mass
Storage devices
Sep 20 08:34:07 localhost kernel: usbcore: registered new driver usb-storage
Sep 20 08:34:07 localhost kernel: USB Mass Storage support registered.
Sep 20 08:34:12 localhost kernel:   Vendor: TOSHIBA   Model: MK8026GAX
       Rev: 0811
Sep 20 08:34:12 localhost kernel:   Type:   Direct-Access
       ANSI SCSI revision: 00
Sep 20 08:34:12 localhost kernel: SCSI device sda: 156301488 512-byte
hdwr sectors (80026 MB)
Sep 20 08:34:12 localhost kernel: sda: assuming drive cache: write through
Sep 20 08:34:12 localhost kernel: SCSI device sda: 156301488 512-byte
hdwr sectors (80026 MB)
Sep 20 08:34:12 localhost kernel: sda: assuming drive cache: write through
Sep 20 08:34:12 localhost kernel:  sda: sda1 sda2 sda3
Sep 20 08:34:12 localhost kernel: Attached scsi disk sda at scsi0,
channel 0, id 0, lun 0
Sep 20 08:34:12 localhost udev[3771]: import_file_into_env: can't open
'/sbin/path_id /block/sda'
Sep 20 08:34:13 localhost udev[3783]: import_file_into_env: can't open
'/sbin/vol_id --export /dev/.tmp-8-1'
Sep 20 08:34:13 localhost udev[3784]: import_file_into_env: can't open
'/sbin/vol_id --export /dev/.tmp-8-2'
Sep 20 08:34:13 localhost udev[3785]: import_file_into_env: can't open
'/sbin/vol_id --export /dev/.tmp-8-3'
Sep 20 08:34:13 localhost fstab-sync[3806]: added mount point
/media/usbdisk for /dev/sda1
Sep 20 08:34:13 localhost fstab-sync[3813]: added mount point
/media/usbdisk1 for /dev/sda2
Sep 20 08:34:13 localhost kernel: kjournald starting.  Commit interval
5 secondsSep 20 08:34:13 localhost kernel: EXT3 FS on sda2, internal
journal
Sep 20 08:34:13 localhost kernel: EXT3-fs: mounted filesystem with
ordered data mode.
Sep 20 08:34:13 localhost udevd[692]: get_netlink_msg: no ACTION in
payload found, skip event 'mount'
Sep 20 08:34:13 localhost kernel: SELinux: initialized (dev sda2, type
ext3), uses xattr

Version-Release number of selected component (if applicable):
udev-069-3

How reproducible:
Always

Steps to Reproduce:
1. plug in USB hard drive
2.
3.
  

Additional info:
Comment 1 Tom London 2005-09-22 10:36:21 EDT
Hmmm.... udev-069-4 fixes '/sbin/vol_id', but now '/sbin/path_id' seems to be
missing (actually, I see it was missing in 069-3 too. Sorry I didn't report it
before).

Also, is 'get_netlink_msg: no ACTION in payload....' message expected?


Sep 22 07:31:32 localhost kernel: usb 1-1: new high speed USB device using
ehci_hcd and address 4
Sep 22 07:31:32 localhost kernel: scsi1 : SCSI emulation for USB Mass Storage
devices
Sep 22 07:31:37 localhost kernel:   Vendor: TOSHIBA   Model: MK8026GAX        
Rev: 0811
Sep 22 07:31:37 localhost kernel:   Type:   Direct-Access                     
ANSI SCSI revision: 00
Sep 22 07:31:37 localhost kernel: SCSI device sdb: 156301488 512-byte hdwr
sectors (80026 MB)
Sep 22 07:31:37 localhost kernel: sdb: assuming drive cache: write through
Sep 22 07:31:37 localhost kernel: SCSI device sdb: 156301488 512-byte hdwr
sectors (80026 MB)
Sep 22 07:31:37 localhost kernel: sdb: assuming drive cache: write through
Sep 22 07:31:37 localhost kernel:  sdb: sdb1 sdb2 sdb3
Sep 22 07:31:37 localhost kernel: Attached scsi disk sdb at scsi1, channel 0, id
0, lun 0
Sep 22 07:31:37 localhost udev[4250]: import_file_into_env: can't open
'/sbin/path_id /block/sdb'
Sep 22 07:31:38 localhost fstab-sync[4290]: added mount point /media/usbdisk for
/dev/sdb2
Sep 22 07:31:39 localhost fstab-sync[4295]: added mount point /media/usbdisk1
for /dev/sdb1
Sep 22 07:31:39 localhost kernel: kjournald starting.  Commit interval 5
secondsSep 22 07:31:39 localhost kernel: EXT3 FS on sdb2, internal journal
Sep 22 07:31:39 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Sep 22 07:31:39 localhost udevd[700]: get_netlink_msg: no ACTION in payload
found, skip event 'mount'
Sep 22 07:31:39 localhost kernel: SELinux: initialized (dev sdb2, type ext3),
uses xattr

Note You need to log in before you can comment on or make changes to this bug.