Bug 168911 - Tomcat5 crashes under BEA java
Tomcat5 crashes under BEA java
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-bea (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Georges Saab
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 04:05 EDT by KSRZIS
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 17:53:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of Tomcat logfile (13.94 KB, text/plain)
2005-09-21 04:07 EDT, KSRZIS
no flags Details

  None (edit)
Description KSRZIS 2005-09-21 04:05:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050825 Firefox/1.0.4 (Debian package 1.0.4-2sarge3)

Description of problem:
If I run tomcat (tomcat5-5.5.9-1jpp_5rh) under java from BEA it crashes when users work with one aplication we provide. The tomcat crashes randomly throughout the use of the application.
We use RHEL4 AS x86_64 and RHAPS2 on dual Opteron 244 Sun Fire 20 vith 2G of memory. 32bit java is used because of some problems with 64bit Oracle klient libraries. Tomcat is run via mod_jk from apache
In catalina.out I see trace I'll attach later.

Version-Release number of selected component (if applicable):
java-1.4.2-bea-1.4.2.05-1jpp_13rh

How reproducible:
Sometimes

Steps to Reproduce:
1. Run tomcat and apache
2. Let users use application


Actual Results:  Tomcat crashes


Expected Results:  Application continues


Additional info:

tomcat5.conf:
# tomcat5 service configuration file

# you could also override JAVA_HOME here
# Where your java installation lives
JAVA_HOME="/usr/lib/jvm/java-1.4.2-bea-1.4.2.05"

# You can pass some parameters to java
# here if you wish to
#JAVA_OPTS="-Xminf0.1 -Xmaxf0.3"
JAVA_OPTS="-Djava.awt.headless=true -Xms768m"

# Where your tomcat installation lives
# That change from previous RPM where TOMCAT_HOME 
# used to be /var/tomcat.
# Now /var/tomcat will be the base for webapps only
CATALINA_HOME="/usr/share/tomcat5"
JASPER_HOME="/usr/share/tomcat5"
CATALINA_TMPDIR="/usr/share/tomcat5/temp"
JAVA_ENDORSED_DIRS="/usr/share/tomcat5/common/endorsed"

# What user should run tomcat
TOMCAT_USER="tomcat"

# You can change your tomcat locale here
#LANG=en_US

# Time to wait in seconds, before killing process
SHUTDOWN_WAIT=30

# Set the TOMCAT_PID location
CATALINA_PID=/var/run/tomcat5.pid

# If you wish to further customize your tomcat environment,
# put your own definitions here
# (i.e. LD_LIBRARY_PATH for some jdbc drivers)
# Just do not forget to export them :)

export ORACLE_HOME=/u01/app/oracle/product/9.2.0
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$ORACLE_HOME/lib32/
export NLS_LANG=american_america.UTF8
Comment 1 KSRZIS 2005-09-21 04:07:18 EDT
Created attachment 119066 [details]
Part of Tomcat logfile
Comment 2 Georges Saab 2006-07-14 08:42:12 EDT
This is running on a version of JRockit from 2004.  There have been at least 3
releases since then, with a great number of bug fixes.

Could you try with the latest JRockit release (26.4), downloadable from
http://www.bea.com/jrockit and let me know if you still see the problem?

Thanks!
Comment 3 Georges Saab 2006-08-23 03:26:15 EDT
Any luck reproducing with JR R26.4?
Comment 4 RHEL Product and Program Management 2006-08-23 17:42:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 RHEL Product and Program Management 2006-08-23 17:42:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Thomas Fitzsimmons 2006-09-18 17:20:12 EDT
We haven't heard back from the reporter yet, but I'm going to hope that R26.4
will fix KSRZIS's problem, and devel_ack this.
Comment 10 Thomas Fitzsimmons 2006-11-03 17:53:50 EST
Closing WONTFIX since we haven't heard back from the reporter.

Note You need to log in before you can comment on or make changes to this bug.