Bug 168940 - Latest Xorg updates results in no usable picture on i865G powered computer
Latest Xorg updates results in no usable picture on i865G powered computer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 10:40 EDT by Peter Zinck Wulff
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 6.8.2-37.FC4.49.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 07:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg, Xorg.0.log, and yum.log from systems02 machine (17.25 KB, application/octet-stream)
2005-09-21 15:33 EDT, Brig C. McCoy
no flags Details
dmesg, Xorg.0.log, and yum.log from "fresh" machine (13.40 KB, application/octet-stream)
2005-09-21 15:34 EDT, Brig C. McCoy
no flags Details
dmesg from systems02 (12.87 KB, text/plain)
2005-09-21 16:31 EDT, Brig C. McCoy
no flags Details
Xorg.0.log for systems02 (59.17 KB, text/plain)
2005-09-21 16:31 EDT, Brig C. McCoy
no flags Details
yum.log for systems02 (26.51 KB, text/plain)
2005-09-21 16:32 EDT, Brig C. McCoy
no flags Details
dmesg for fresh (13.94 KB, text/plain)
2005-09-21 16:32 EDT, Brig C. McCoy
no flags Details
Xorg.0.log for the machine "fresh" (42.24 KB, text/plain)
2005-09-21 16:33 EDT, Brig C. McCoy
no flags Details
yum.log for the machine "fresh" (8.01 KB, text/plain)
2005-09-21 16:33 EDT, Brig C. McCoy
no flags Details

  None (edit)
Description Peter Zinck Wulff 2005-09-21 10:40:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Using the latest updates of Xorg results in totally f*cked up graphics after reboot, on my HP deskpro d530 powered by an internal i865G gfx card. I was running FC3, then updated, and I was unable to see anything. So I reinstalled with FC4, clean install, no problem, until I did an update of all packages, same problem after reboot.

Even the startup screen after grub bootloader is messed up!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fresh FC3 or FC4
2. yum update
3. reboot
  

Actual Results:  Graphics are totally messed up, it looks like garbage(Kinda like when a C=64 decrunshed, just over the entire screen).

Expected Results:  Startup picture would show and eventually login screen.

Additional info:

Standard install, personal desktop.
Comment 1 Brig C. McCoy 2005-09-21 15:33:56 EDT
Created attachment 119093 [details]
dmesg, Xorg.0.log, and yum.log from systems02 machine
Comment 2 Brig C. McCoy 2005-09-21 15:34:43 EDT
Created attachment 119094 [details]
dmesg, Xorg.0.log, and yum.log from "fresh" machine
Comment 3 Brig C. McCoy 2005-09-21 15:36:32 EDT
Running into the same problem on MPC desktop with Intel 865G. Systems02 machine
has custom configuration with "all" packages loaded. "fresh" machine has just
desktop packages loaded.
Comment 4 Mike A. Harris 2005-09-21 16:11:22 EDT
>Version-Release number of selected component (if applicable):

You left this field blank.  Please provide this information.  Also, when
attaching files, attach each file as a separate bugzilla text file
attachment so that they are web browser viewable.

Thanks in advance.

Setting state to NEEDINFO_REPORTER.

Comment 5 Brig C. McCoy 2005-09-21 16:29:03 EDT
Sorry, version is xorg-x11-6.8.2-37.FC4.48.1.

Dmesg, Xorg.0.log, and yum.log from systems02 and fresh attached as separate
text files.


Comment 6 Brig C. McCoy 2005-09-21 16:31:10 EDT
Created attachment 119101 [details]
dmesg from systems02
Comment 7 Brig C. McCoy 2005-09-21 16:31:46 EDT
Created attachment 119102 [details]
Xorg.0.log for systems02
Comment 8 Brig C. McCoy 2005-09-21 16:32:13 EDT
Created attachment 119103 [details]
yum.log for systems02
Comment 9 Brig C. McCoy 2005-09-21 16:32:42 EDT
Created attachment 119104 [details]
dmesg for fresh
Comment 10 Brig C. McCoy 2005-09-21 16:33:20 EDT
Created attachment 119105 [details]
Xorg.0.log for the machine "fresh"
Comment 11 Brig C. McCoy 2005-09-21 16:33:46 EDT
Created attachment 119106 [details]
yum.log for the machine "fresh"
Comment 12 Brig C. McCoy 2005-09-22 11:15:24 EDT
Update to xorg-x11-6.8.2-37.FC4.49.2 seems to have fixed things. Thank you very 
much.
Comment 13 Mike A. Harris 2005-09-26 22:30:01 EDT
Brig: It appears you were hit by the pci-config regression, which is solved
in the current update.  Thanks for the feedback.


Original reporter:  Please update the bug report to indicate wether the
latest update still has this problem for you or not.  If the current update
still has the problem, please indicate the exact rpm package version-release
of xorg (rpm -qa |grep xorg-x11 |sort), and attach your X server log file
and config file.

Note You need to log in before you can comment on or make changes to this bug.