Bug 168961 - yum has dep resolve problems on x86_64
yum has dep resolve problems on x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 14:05 EDT by Steve Grubb
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum debug output (18.39 KB, text/plain)
2005-09-21 14:07 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2005-09-21 14:05:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
When doing "yum update glibc-headers" yum fails resolving the dependencies.

Dep Number: 1/2
glibc-devel requires: glibc = 2.3.90-11
--> Processing Dependency: glibc = 2.3.90-11 for package: glibc-devel
Calling rpmdb.returnHeaderByTuple on glibc-devel.x86_64 0:2.3.90-11
Calling rpmdb.returnHeaderByTuple on glibc-devel.i386 0:2.3.90-11
Multiple Packages match. glibc-devel-2.3.90-11
   glibc-devel - 2.3.90-11.x86_64
   glibc-devel - 2.3.90-11.i386 already in ts u, skipping
Requiring package is installed: glibc-devel - 2.3.90-11.x86_64
Resolving for installed requiring package: glibc-devel - 2.3.90-11.x86_64
Resolving for requirement: glibc = 2.3.90-11
Potential Provider: glibc.i686 0:2.3.90-12


Version-Release number of selected component (if applicable):
yum-2.4.0-3.1

How reproducible:
Always

Steps to Reproduce:
1. yum update glibc-headers

Actual Results:  --> Running transaction check
--> Processing Dependency: glibc = 2.3.90-11 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.3.90-11 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.3.90-11, this is not available.
Error: Package glibc-devel needs glibc-headers = 2.3.90-11, this is not available.


Additional info:

[root@spirit yum]# yum list glibc\*
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Installed Packages
glibc.x86_64                             2.3.90-11              installed
glibc.i686                               2.3.90-11              installed
glibc-common.x86_64                      2.3.90-11              installed
glibc-devel.x86_64                       2.3.90-11              installed
glibc-devel.i386                         2.3.90-11              installed
glibc-headers.x86_64                     2.3.90-11              installed
glibc-kernheaders.x86_64                 2.4-9.1.95             installed
Available Packages
glibc.x86_64                             2.3.90-12              development
glibc.i686                               2.3.90-12              development
glibc-common.x86_64                      2.3.90-12              development
glibc-debuginfo.x86_64                   2.3.90-12              development
glibc-devel.i386                         2.3.90-12              development
glibc-devel.x86_64                       2.3.90-12              development
glibc-headers.x86_64                     2.3.90-12              development
glibc-profile.x86_64                     2.3.90-12              development
glibc-utils.x86_64                       2.3.90-12              development
Comment 1 Steve Grubb 2005-09-21 14:07:53 EDT
Created attachment 119088 [details]
yum debug output
Comment 2 Seth Vidal 2005-09-30 00:35:33 EDT
1. Are you still seeting this problem? Was it just a temporary repository error?
2. if you're not seeing the problem - close the bug
3. if you are seeing the problem can you tell me if you get the same problem
when you run: yum update glibc*

thanks
Comment 3 Steve Grubb 2005-09-30 08:42:01 EDT
1. yes this bug still exists.
3. Running "yum update glibc*" succeeds.
4. Since #3 succeeds, I had to find a new way to reproduce the problem. "yum
update cyrus-sasl-lib.i386" fails:

--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Missing Dependency: cyrus-sasl-lib = 2.1.21-4 is needed by package cyrus-sasl
Error: Unable to satisfy dependencies
Error: Package cyrus-sasl-md5 needs cyrus-sasl-lib = 2.1.21-4, this is not
available.
Error: Package cyrus-sasl needs cyrus-sasl-lib = 2.1.21-4, this is not available.
Error: Package cyrus-sasl-plain needs cyrus-sasl-lib = 2.1.21-4, this is not
available.
Comment 4 Jeremy Katz 2006-04-19 16:07:10 EDT
This was caused by repository weirdness and some change of the multilib set of
time in the devel tree

Note You need to log in before you can comment on or make changes to this bug.