Bug 168984 - PyXML is suspected for iso-codes not building with Gnome 2.12
PyXML is suspected for iso-codes not building with Gnome 2.12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PyXML (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 16:27 EDT by Ali Sobhi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Sobhi 2005-09-21 16:27:13 EDT
Description of problem:
Building Gnome 2.12 using JHBUILD (9/21/2005) it breaks on building iso-codes
../iso2pot.py --is-version 0.47 --comments iso_639_2T_code \
                --fields name iso_639.xml iso_639.pot
Traceback (most recent call last):
  File "../iso2pot.py", line 102, in ?
    p = make_parser()
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/sax2exts.py", line 37, in
make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/saxexts.py", line 75, in
make_parser
    sys.modules[parser_name].create_parser = _create_parser
KeyError: 'xml.sax.drivers2.drv_pyexpat'

make[1]: [iso_639.pot] Error 1


make[1]: Leaving directory `/opt/lap/g2src/cvs/2.12/src/iso-codes-0.48/iso_639'


Version-Release number of selected component (if applicable):


How reproducible:
every time.

Steps to Reproduce:
1.build Gnome 2.12 using jhbuild on FC4
2.
3.
  
Actual results:
../iso2pot.py --is-version 0.47 --comments iso_639_2T_code \
                --fields name iso_639.xml iso_639.pot
Traceback (most recent call last):
  File "../iso2pot.py", line 102, in ?
    p = make_parser()
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/sax2exts.py", line 37, in
make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/saxexts.py", line 75, in
make_parser
    sys.modules[parser_name].create_parser = _create_parser
KeyError: 'xml.sax.drivers2.drv_pyexpat'

make[1]: [iso_639.pot] Error 1


make[1]: Leaving directory `/opt/lap/g2src/cvs/2.12/src/iso

Expected results:
no error

Additional info:
http://bugzilla.gnome.org/show_bug.cgi?id=316116
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=328152

email from iso-codes maintainer (Debian):

tags 328152 moreinfo
thanks

Hi,

I've investigated this bug and can't reproduce it.
The build appears to have failed on python2.4-xml (or its equivalent in 
FC4);
it does not fail on either python2.3 or python2.4 in Debian.

Can you please ensure that your python installation is correct? the
program ./iso2pot.py is breaking on a perfectly correct call. It appears
that python-xml is incorrectly set up on your build environment.

Regards
Alastair
Comment 1 Florian La Roche 2005-09-28 17:58:49 EDT
This seems fixed in our development tree.

Note You need to log in before you can comment on or make changes to this bug.