Bug 168985 - xorg hangs or freezes system with multiple ATI cards
xorg hangs or freezes system with multiple ATI cards
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 16:33 EDT by Laurie Reeves
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-6.8.2-37.FC4.49.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 15:22:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurie Reeves 2005-09-21 16:33:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Latest xorg update hangs while starting (xorg process using 100% cpu) or causes entire system to freeze (can't ssh in).

This has been duplicated on 3 different machines with 2 and 3 video cards. Removing all but one card seems to fix it. Seems not to matter it it's AGP or PCI.

Have fiddled with several different X configurations. Starting on X on all screens, some screens, and one screen. Always produces same result.

I feel this is not a duplicate of Bugs 168940, 168937, 168919, or 165116, but may have common cause.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.48.1

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 + all updates on a system with multiple ATI Radon 7000
2. Reboot, (re)start X, etc
3. Wait
  

Actual Results:  Black screens. Sometimes can SSH in and see X throttling CPU, sometimes SSH machine is fully hung and connection times out.

Expected Results:  Graphical bliss.

Additional info:
Comment 1 Frank Ch. Eigler 2005-09-22 11:15:14 EDT
I'm seeing the same thing.  I have saved copies of Xorg.log files from a hung vs
successful run, if they help.
Comment 2 Mike A. Harris 2005-09-22 13:59:06 EDT
xorg-x11-6.8.2-37.FC4.49.2 is the current update.  Please upgrade to that
and indicate if the problem still exists or not.  If it does, attach your
X server log and config file to the bug report as individual uncompressed
file attachments.
Comment 3 Laurie Reeves 2005-09-22 14:55:07 EDT
Tested new update on fresh install with 1, 2, and 3 cards. It works.

Thanks.
Comment 4 Mike A. Harris 2005-09-22 15:22:17 EDT
Thanks for testing.

Setting status to "ERRATA" (fixed in xorg-x11-6.8.2-37.FC4.49.2)

Note You need to log in before you can comment on or make changes to this bug.