Bug 169025 - system-config-lvm hangs when loading
system-config-lvm hangs when loading
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 06:31 EDT by dominique
Modified: 2009-04-16 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0.5-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 08:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dominique 2005-09-22 06:31:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
When I want display LVM display in graphical mode I've this error:
File descriptor 13 left open
Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 131, in ?
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 116, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 70, in __init__
    self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm, self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 131, in __init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 226, in prepare_tree
    pv_list = self.model_factory.query_PVs_for_VG(vg_name)
  File "/usr/share/system-config-lvm/lvm_model.py", line 295, in query_PVs_for_VG
    pv_s = self.query_PVs()
  File "/usr/share/system-config-lvm/lvm_model.py", line 287, in query_PVs
    self.get_extents_for_PV(pv)
  File "/usr/share/system-config-lvm/lvm_model.py", line 956, in get_extents_for_PV
    st,sz = extentlist[len(extentlist) - 1].get_start_size()
IndexError: list index out of range


Version-Release number of selected component (if applicable):
system-config-lvm-0.9.24-1.0

How reproducible:
Always

Steps to Reproduce:
1.system-config-lvm
2.
3.
  

Additional info:
Comment 1 Stanko Kupcevic 2005-09-22 11:59:40 EDT
s-c-lvm has undergone many changes since 0.9.24.

Could you upgrade to current version, 1.0.5, and test it?
Comment 2 Stanko Kupcevic 2005-09-22 15:59:38 EDT
1.0.5 will be included in RHEL4 U2
Comment 3 dominique 2005-09-23 02:47:21 EDT
where I can found it please ?
Comment 4 dominique 2005-09-23 02:48:24 EDT
where I can found it please ?

Comment 5 Stanko Kupcevic 2005-09-23 11:42:50 EDT
You can get it from RHN beta channels, ahead of official RHEL4 U2 release.
Comment 6 dominique 2005-09-23 11:53:24 EDT
(In reply to comment #5)
> You can get it from RHN beta channels, ahead of official RHEL4 U2 release.

Ok that's now work
Thanks
Comment 8 Stanko Kupcevic 2005-10-25 17:42:06 EDT
Could you please verify that this issue has been fixed.

I'd like to close this bug, if it has been resolved.
Comment 9 Stanko Kupcevic 2005-10-26 12:26:08 EDT
Reporter closed this bug. 
Changing to closed currentrelease.

Note You need to log in before you can comment on or make changes to this bug.