Bug 169041 - 'find' command warning during install of kernel-2.6.13-1.1567_FC5
'find' command warning during install of kernel-2.6.13-1.1567_FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 09:49 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 14:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2005-09-22 09:49:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
get the following messages during yum update of kernel-2.6.13-1.1567_FC5:

  Updating  : ethereal-gnome               ####################### [30/60]
  Installing: kernel                       ####################### [31/60]
WARNING: /lib/modules/2.6.13-1.1567_FC5/kernel/sound/usb/snd-usb-audio.ko needs unknown symbol __compound_literal.127
WARNING: /lib/modules/2.6.13-1.1567_FC5/kernel/sound/usb/snd-usb-audio.ko needs unknown symbol __compound_literal.188
<<<< SNIP: Lots of similar warning messages >>>>
WARNING: /lib/modules/2.6.13-1.1567_FC5/kernel/sound/usb/snd-usb-audio.ko needs unknown symbol __compound_literal.196
WARNING: /lib/modules/2.6.13-1.1567_FC5/kernel/sound/usb/snd-usb-audio.ko needs unknown symbol __compound_literal.129
WARNING: /lib/modules/2.6.13-1.1567_FC5/kernel/sound/usb/snd-usb-audio.ko needs unknown symbol __compound_literal.200
find: warning: Unix filenames usually don't contain slashes (though pathnames do).  That means that '-name /dev/hda3' will probably evaluate to false all the time on this system.  You might find the '-wholename' test more useful, or perhaps '-samefile'.  Alternatively, if you are using GNU grep, you could use 'find ... -print0 | grep -FzZ /dev/hda3'.
  Cleanup   : policycoreutils              ####################### [32/60]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. 'yum update'
2.
3.
  

Additional info:
Comment 1 Frank Arnold 2005-09-22 12:13:11 EDT
Should be moved to mkinitrd.
I don't see this on my system but got the message 'Found root device /dev/hda1'
during install. This message is triggered by mkinitrd, which contains 'find'
with '-name' switch and was updated today (4.2.22-1).
Comment 2 Michal Jaegermann 2005-10-01 14:42:44 EDT
The orginal report is really confusing. "..unknown symbol __compound_literal.xxx"
messages are really coming from the kernel, this is a duplicate of bug
#168988, and it looks like that gcc-4.0.1 is really the culprit.  See
http://marc.theaimsgroup.com/?l=linux-kernel&m=112817350819818&w=2

Only now I noticed that at the bottom of all that is tacked a real mkinitrd
issue.  In bug #169661 there is a more precise description.
Comment 3 Frank Arnold 2005-10-02 02:00:26 EDT
Sorry. I didn't take these __compound_literal warnings serious because this
problem was known to me. It's fixed anyway:
gcc-4.0.2-1
-----------
* Fr Sep 30 2005 Jakub Jelinek  <jakub@redhat.com> 4.0.2-1
- fix a bug which caused undefined __compound_literal.* symbols
  on Linux kernel (PR middle-end/24109)

The mkinitrd issue should be fixed too (works for me):
mkinitrd-5.0.3-1
----------------
* Sa Okt 01 2005 Peter Jones <pjones@redhat.com> - 5.0.3-1
- fix root dev discovery to give us "hda3" and such again, rather than
  a full sysfs path

Note You need to log in before you can comment on or make changes to this bug.