Bug 169127 - require 'rbconfig' fails on x86_64
require 'rbconfig' fails on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 09:31 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.8.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-26 22:27:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test script (309 bytes, text/plain)
2005-09-23 09:31 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-09-23 09:31:45 EDT
Description of problem:
The line "require 'rbconfig'" in a ruby script fails on x86_64, but works on i386.

Version-Release number of selected component (if applicable):
ruby-1.8.3-1
ruby-devel-1.8.3-1

How reproducible:
100%

Steps to Reproduce:
1.ruby ./config_ruby.rb INCLUDES
2.
3.
  
Actual results:
./config_ruby.rb:1:in `require': no such file to load -- rbconfig (LoadError)
        from ./config_ruby.rb:1


Expected results:
/usr/lib64/ruby/1.8/x86_64-linux/

Additional info:
Comment 1 John Ellson 2005-09-23 09:31:45 EDT
Created attachment 119179 [details]
test script
Comment 2 Akira TAGOH 2005-09-26 05:08:16 EDT
Ok, the problem is that the multilib support for the load path was broken again.
this problem should be fixed in 1.8.3-2.

Note You need to log in before you can comment on or make changes to this bug.