Bug 169137 - kernel oops when unplugging iPod: unable to handle kernel paging request
kernel oops when unplugging iPod: unable to handle kernel paging request
Status: CLOSED DUPLICATE of bug 159086
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 11:27 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 15:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2005-09-23 11:27:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
Unplugged iPod (which was not correctly mounted at boot):

Sep 23 08:23:23 localhost kernel: Unable to handle kernel paging request at virtual address 6b6b6bb3
Sep 23 08:23:23 localhost kernel:  printing eip:
Sep 23 08:23:23 localhost kernel: f8a73804
Sep 23 08:23:23 localhost kernel: *pde = 00000000
Sep 23 08:23:23 localhost kernel: Oops: 0002 [#1]
Sep 23 08:23:23 localhost kernel: Modules linked in: vmnet(U) parport_pc vmmon(U) ppdev lp autofs4 sunrpc ipt_REJECT ipt_state ip_conntrack nfnetlink iptable_filter ip_tables video toshiba_acpi button battery ac sd_mod usb_storage ohci1394 scsi_mod ieee1394 uhci_hcd ehci_hcd parport hw_random tpm_nsc tpm i2c_i801 i2c_core snd_intel8x0m snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc ipw2200 ieee80211 ieee80211_crypt e1000 dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod
Sep 23 08:23:23 localhost kernel: CPU:    0
Sep 23 08:23:23 localhost kernel: EIP:    0060:[<f8a73804>]    Tainted: P      VLI
Sep 23 08:23:23 localhost kernel: EFLAGS: 00010286   (2.6.13-1.1570_FC5)
Sep 23 08:23:23 localhost kernel: EIP is at scsi_remove_device+0x2c/0x38 [scsi_mod]
Sep 23 08:23:23 localhost kernel: eax: 00000001   ebx: f7134ad4   ecx: 00000000   edx: 6b6b6b6b
Sep 23 08:23:23 localhost kernel: esi: f71c436c   edi: f71c436c   ebp: f7142760   esp: f7e13e84
Sep 23 08:23:23 localhost kernel: ds: 007b   es: 007b   ss: 0068
Sep 23 08:23:23 localhost kernel: Process khubd (pid: 127, threadinfo=f7e13000 task=f7fda030)
Sep 23 08:23:23 localhost kernel: Stack: badc0ded f7134ad4 f71c4364 f8a7388f f7142760 f71c4370 f71c436c f71c4374
Sep 23 08:23:23 localhost kernel:        f8a72a09 f71c436c f8b07ac0 f8b07ae0 f70eaa94 f8a6b3a2 f71c4654 f8b07ac0
Sep 23 08:23:23 localhost kernel:        f8af883b f70ba0bc c0286d65 f70ba178 f70ba0d0 c023e5da f70ba0d0 f70eab08
Sep 23 08:23:23 localhost kernel: Call Trace:
Sep 23 08:23:23 localhost kernel:  [<f8a7388f>] __scsi_remove_target+0x7f/0xb6 [scsi_mod]
Sep 23 08:23:23 localhost kernel:  [<f8a72a09>] scsi_forget_host+0x37/0x5c [scsi_mod]
Sep 23 08:23:23 localhost kernel:  [<f8a6b3a2>] scsi_remove_host+0x3d/0x7a [scsi_mod]
Sep 23 08:23:23 localhost kernel:  [<f8af883b>] storage_disconnect+0xe/0x16 [usb_storage]
Sep 23 08:23:23 localhost kernel:  [<c0286d65>] usb_unbind_interface+0x34/0x60
Sep 23 08:23:23 localhost kernel:  [<c023e5da>] __device_release_driver+0x4c/0x64
Sep 23 08:23:23 localhost kernel:  [<c023e61c>] device_release_driver+0x2a/0x38
Sep 23 08:23:23 localhost kernel:  [<c023df74>] bus_remove_device+0x4f/0x5d
Sep 23 08:23:23 localhost kernel:  [<c023d2b3>] device_del+0x2b/0x5b
Sep 23 08:23:23 localhost kernel:  [<c028de8a>] usb_disable_device+0xbb/0x108
Sep 23 08:23:23 localhost kernel:  [<c0289078>] usb_disconnect+0xaa/0x14c
Sep 23 08:23:23 localhost kernel:  [<c0289efa>] hub_port_connect_change+0x51/0x393
Sep 23 08:23:24 localhost kernel:  [<c028a4b3>] hub_events+0x277/0x3bc
Sep 23 08:23:24 localhost kernel:  [<c028a5f8>] hub_thread+0x0/0xe5
Sep 23 08:23:24 localhost kernel:  [<c028a60c>] hub_thread+0x14/0xe5
Sep 23 08:23:24 localhost kernel:  [<c012dd16>] autoremove_wake_function+0x0/0x37
Sep 23 08:23:24 localhost kernel:  [<c012d8fb>] kthread+0x87/0x8b
Sep 23 08:23:24 localhost kernel:  [<c012d874>] kthread+0x0/0x8b
Sep 23 08:23:24 localhost kernel:  [<c01012fd>] kernel_thread_helper+0x5/0xb
Sep 23 08:23:24 localhost kernel: Code: 53 89 c3 8b 30 ba 66 00 00 00 b8 05 8c a7 f8 e8 e5 4f 6a c7 e8 4c 86 8a c7 ff 4e 48 0f 88 a4 03 00 00 89 d8 e8 73 ff ff ff 8b 13 <ff> 42 48 0f 8e 9f 03 00 00 5b 5e c3 55 57 56 53 89 c5 8b 98 b8



Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1570_FC5

How reproducible:
Didn't try

Steps to Reproduce:
1. Boot with iPod plugged in
2. unplug iPod
3.
  

Additional info:
Comment 1 Dave Jones 2005-09-23 15:40:09 EDT

*** This bug has been marked as a duplicate of 159086 ***

Note You need to log in before you can comment on or make changes to this bug.