Bug 169151 - Kernel fails to boot, HDA: Interrupt Lost
Summary: Kernel fails to boot, HDA: Interrupt Lost
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-23 17:33 UTC by Daniel Walsh
Modified: 2013-07-03 02:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 18:53:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New Kernel with ide1=noprobe (20.10 KB, text/plain)
2005-10-06 14:54 UTC, Daniel Walsh
no flags Details
With the working kernel 2.6.13-1.1542_FC5 (16.33 KB, text/plain)
2005-10-06 14:55 UTC, Daniel Walsh
no flags Details

Description Daniel Walsh 2005-09-23 17:33:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
All kernels since

kernel-2.6.13-1.1542_FC5

Have been broken.


Machine fails to complete boot.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1570_FC5

How reproducible:
Always

Steps to Reproduce:
1.Reboot
2.
3.
  

Additional info:

 more /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 2.00GHz
stepping        : 8
cpu MHz         : 798.195
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx est tm2
bogomips        : 1598.46

Comment 1 Dave Jones 2005-10-06 06:52:47 UTC
I'm (still) at a loss on this one right now.

can you attach dmesg -s 128000 output from the last working kernel please?

also, if you boot with init=/bin/bash, does it get far enough to give you a shell ?
if so, doing the same, and dumping it somewhere like /tmp/dmesg.new for later
attaching here may also have some clues.


Comment 2 Daniel Walsh 2005-10-06 11:30:07 UTC
One hint, is that I can boot the new kernels if I add the following to the boot
line.

ide1=noprobe

The CDRom drive does not work if I do this.

I will attach the dmesg info in the next attachment


Comment 3 Daniel Walsh 2005-10-06 14:54:23 UTC
Created attachment 119671 [details]
New Kernel with ide1=noprobe

Could not boot without noprobe line.  

Without the line I get the following interesting lines

1F0 IDE Port Busy
170 IDE Port Busy

ATA_PIIX Probe of 0000:00:1F Failed with Error -16
...
AHCI Probe of 0000:00:1F[B] Failed with Error -12

Comment 4 Daniel Walsh 2005-10-06 14:55:17 UTC
Created attachment 119672 [details]
With the working kernel 2.6.13-1.1542_FC5

Comment 5 Dave Jones 2005-10-06 19:59:04 UTC
ahhh, I've met this one before.
booting with hda=noprobe should have the same effect (and make your CD drive work).

The big question is why the probe order of libata/ide changed.


Comment 6 Mike Cohler 2005-11-08 16:29:53 UTC
This may be a dumb question but is there anything linking bug 171487 to this one ?


Comment 7 Daniel Walsh 2006-01-02 18:53:42 UTC
This seems to be fixed with the latest kernel.  I can boot without hda=noprobe
 and the cdrom still works.

2.6.14-1.1807_FC5


Note You need to log in before you can comment on or make changes to this bug.