Bug 169165 - 64bit and 32bit libraries are not installed together
Summary: 64bit and 32bit libraries are not installed together
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssl
Version: 4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-23 20:45 UTC by Joseph Shraibman
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-09-30 07:43:58 UTC


Attachments (Terms of Use)

Description Joseph Shraibman 2005-09-23 20:45:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
I have a 32 bit program that I need to run on my rhel 4 x86_64 install that won't run because only the 64 bit libraries are installed. Furthermore I can't install the 32 bit rpms on the cd because they conflict with the 64 bit rpms.

This is the same bug as bug 156331 but that doesn't emphasize the severity of the problem.  This is a big blunder not being able to have both the 32 bit and 64 bit libraries installed at the same time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a 64 bit system
2.
3.
  

Actual Results:  ./sanmgrd: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

Additional info:

This is not just a problem with openssl, it is a problem for many libraries.

Comment 1 Tomas Mraz 2005-09-26 09:30:14 UTC
Both up2date -i --arch=i686 openssl or rpm -Uvh openssl-0.9.7a-43.2.i686.rpm
install without conflicts.

Could you please specify what exactly conflicts for you with output from rpm or
up2date?


Comment 2 Tomas Mraz 2005-09-26 09:32:36 UTC
Also note that bug 156331 is about development packages (openssl-devel in this
case) not about the library packages. Multilib development is currently not
supported because it is much more tricky than multilib environment for executables.


Comment 3 Joseph Shraibman 2005-09-30 01:09:04 UTC
# rpm -ivh openssl-0.9.7a-43.1.i686.rpm zlib-1.2.1.2-1.i386.rpm
krb5-libs-1.3.4-9.i386.rpm e2fsprogs-1.35-11.6.EL4.i386.rpm
Preparing...                ########################################### [100%]
        package e2fsprogs-1.35-12.1.EL4 (which is newer than
e2fsprogs-1.35-11.6.EL4) is already installed
        package krb5-libs-1.3.4-17 (which is newer than krb5-libs-1.3.4-9) is
already installed
        package zlib-1.2.1.2-1.2 (which is newer than zlib-1.2.1.2-1) is already
installed
        package openssl-0.9.7a-43.2 (which is newer than openssl-0.9.7a-43.1) is
already installed
        file /usr/share/man/man8/mke2fs.8.gz from install of
e2fsprogs-1.35-11.6.EL4 conflicts with file from package e2fsprogs-1.35-12.1.EL4
        file /usr/share/man/man8/mkfs.ext2.8.gz from install of
e2fsprogs-1.35-11.6.EL4 conflicts with file from package e2fsprogs-1.35-12.1.EL4
        file /usr/share/man/man8/mkfs.ext3.8.gz from install of
e2fsprogs-1.35-11.6.EL4 conflicts with file from package e2fsprogs-1.35-12.1.EL4


Comment 4 Tomas Mraz 2005-09-30 07:43:58 UTC
You must install the same versions for both 64bit and 32bit packages. Although
it could probably be seen as rpm's problem that it doesn't allow installing
different versions. But I think solving it could bring more complications than
would be solved.


Comment 5 Joseph Shraibman 2005-09-30 17:14:40 UTC
I can't.  I already used up2date to upgraded those libraries, and I can't get
the updated 32bit versions because they aren't on a public website I can
download them from.


Note You need to log in before you can comment on or make changes to this bug.