Bug 169198 - ghostscript upgrade breaks cups
ghostscript upgrade breaks cups
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 169304 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-24 11:13 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 8.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 13:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-09-24 11:13:57 EDT
Description of problem:

D [24/Sep/2005:11:01:32 -0400] [Job 267] Starting renderer
D [24/Sep/2005:11:01:32 -0400] [Job 267] JCL: <job data>
D [24/Sep/2005:11:01:32 -0400] [Job 267]
D [24/Sep/2005:11:01:32 -0400] [Job 267] renderer PID kid4=16041
D [24/Sep/2005:11:01:32 -0400] [Job 267] renderer command: gs -q -dBATCH
-dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs
-sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="deskjet 3320"
-dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=842 -r300
-sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1
-dIjsUseOutputFD -sOutputFile=- -
D [24/Sep/2005:11:01:32 -0400] [Job 267] foomatic-gswrapper: gs '-dBATCH'
'-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs'
'-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=deskjet 3320'
'-dDEVICEWIDTHPOINTS=595' '-dDEVICEHEIGHTPOINTS=842' '-r300'
'-sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1'
'-dIjsUseOutputFD' '-sOutputFile=| cat >&3' '/dev/fd/0' 3>&1 1>&2
D [24/Sep/2005:11:01:32 -0400] [Job 267] ESP Ghostscript 815.01: Can't find
initialization file gs_init.ps.
D [24/Sep/2005:11:01:32 -0400] [Job 267] renderer return value: 1
D [24/Sep/2005:11:01:32 -0400] [Job 267] renderer received signal: 1
D [24/Sep/2005:11:01:32 -0400] [Job 267] Process dying with "Possible error on
renderer command line or PostScript error. Check options.", exit stat: 3
D [24/Sep/2005:11:01:32 -0400] [Job 267] error: Illegal seek (29)
D [24/Sep/2005:11:01:32 -0400] [Job 267] Possible error on renderer command line
or PostScript error. Check options.
D [24/Sep/2005:11:01:32 -0400] [Job 267] tail process done writing data to STDOUT
D [24/Sep/2005:11:01:32 -0400] [Job 267] KID4 finished
D [24/Sep/2005:11:01:32 -0400] [Job 267]
D [24/Sep/2005:11:01:32 -0400] [Job 267] Closing renderer
D [24/Sep/2005:11:01:32 -0400] [Job 267] KID3 exited with status 3
D [24/Sep/2005:11:01:32 -0400] [Job 267] Renderer exit stat: 3
D [24/Sep/2005:11:01:32 -0400] [Job 267] Renderer process finished
D [24/Sep/2005:11:01:32 -0400] [Job 267] Killing process 16040 (KID3)
D [24/Sep/2005:11:01:32 -0400] [Job 267] Process dying with "Error closing
renderer", exit stat: 3


Version-Release number of selected component (if applicable):
cups-1.1.23-17
ghostscript-8.15.1-0.1


How reproducible:
100%

Steps to Reproduce:
1.lpr hello.txt
2.
3.
  
Actual results:
no printout
see above fragment from /var/log/cups/error_log generated with "LogLevel debug"
in /etc/cups/cupsd.conf

Expected results:
working printer

Additional info:
reverting to ghostscript-8.15-0.rc4.3
Comment 1 John Ellson 2005-09-24 11:15:41 EDT
This was on x86_64
Comment 2 John Ellson 2005-09-24 11:16:45 EDT
Intended to say that: reverting to ghostscript-8.15-0.rc4.3 fixed the problem
Comment 3 Roozbeh Pournader 2005-09-25 08:55:03 EDT
The same problem exists here with ghostscript-8.15.1-0.1 on an i686 machine.
Comment 4 Roozbeh Pournader 2005-09-25 09:16:13 EDT
The component should be changed to "ghostscript", the Severity to "high" (as it
breaks printing completely), and hardware to "All".
Comment 5 Tim Waugh 2005-09-26 16:26:33 EDT
*** Bug 169304 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.