Bug 169212 - Post installation tasks fail for xerces-j2, xalan-j2 and xml-commons-apis
Post installation tasks fail for xerces-j2, xalan-j2 and xml-commons-apis
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xerces-j2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Archit Shah
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-24 23:06 EDT by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 16:26:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2005-09-24 23:06:56 EDT
Description of problem:
Various post installation scripts fail for those 3 packages on yum update.

Version-Release number of selected component (if applicable):
xalan-j2-2.6.0-3jpp_3fc
xerces-j2-2.6.2-5jpp_2fc
xml-commons-apis-1.0-0.b2.7jpp_3fc

How reproducible:
On yum update.

Steps to Reproduce:
1. Run yum update.

  
Actual results:
---------------------------------------
  Installing: xml-commons-apis             ##################### [ 22/102] 
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
dirname: too few arguments
Try `dirname --help' for more information.
mkdir: too few arguments
Try `mkdir --help' for more information.
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
find: .d: No such file or directory
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
error: %post(xml-commons-apis-1.0-0.b2.7jpp_3fc.i386) scriptlet failed, exit sta
tus 123
---------------------------------------

---------------------------------------
  Installing: xerces-j2                    ##################### [ 53/102] 
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
dirname: too few arguments
Try `dirname --help' for more information.
mkdir: too few arguments
Try `mkdir --help' for more information.
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
find: .d: No such file or directory
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
error: %post(xerces-j2-2.6.2-5jpp_2fc.i386) scriptlet failed, exit status 123
  Installing: xalan-j2                     ##################### [ 54/102] 
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
dirname: too few arguments
Try `dirname --help' for more information.
mkdir: too few arguments
Try `mkdir --help' for more information.
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
find: .d: No such file or directory
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NumberFormatException
   <<No stacktrace available>>
error: %post(xalan-j2-2.6.0-3jpp_3fc.i386) scriptlet failed, exit status 123
---------------------------------------

Expected results:
Clean update.

Additional info:
Comment 1 Archit Shah 2005-11-03 16:26:08 EST
Not sure what the problem was, but I failed to reproduce it on two recent
rawhides. Please reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.