Bug 169216 - Selinux packages contain conflicting files
Selinux packages contain conflicting files
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-25 01:29 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 15:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-09-25 01:29:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
IMHO non-conflicting packages should not contain conflicting files. Maybe put those in common selinux-docs ? Yes, I think selinux-policy-* should stay non-conflicting if they can.

[root@cobra packages]# rpm -Uvh libgnomeprint* sqlite* system-config* sendmail* selinux* libsetrans* libsemanage* libicu* lvm* m4* man* wget* wire* xchat* kudzu* krb5* setools* sip* slib* slocate* spam*  libselinux* hwdata* rhpl*
Preparing...                ########################################### [100%]
        file /usr/share/man/man8/ftpd_selinux.8.gz from install of selinux-policy-strict-1.27.1-7 conflicts with file from package selinux-policy-mls-1.25.4-11
        file /usr/share/man/man8/rsync_selinux.8.gz from install of selinux-policy-strict-1.27.1-7 conflicts with file from package selinux-policy-mls-1.25.4-11
        file /usr/share/man/man8/ftpd_selinux.8.gz from install of selinux-policy-targeted-1.27.1-7 conflicts with file from package selinux-policy-mls-1.25.4-11
        file /usr/share/man/man8/rsync_selinux.8.gz from install of selinux-policy-targeted-1.27.1-7 conflicts with file from package selinux-policy-mls-1.25.4-11

/usr/share/man/man8/ftpd_selinux.8.gz      
/usr/share/man/man8/pam_selinux.8.gz
/usr/share/man/man8/httpd_selinux.8.gz     /usr/share/man/man8/pam_selinux_check.8.gz
/usr/share/man/man8/kerberos_selinux.8.gz  /usr/share/man/man8/rsync_selinux.8.gz
/usr/share/man/man8/named_selinux.8.gz     /usr/share/man/man8/samba_selinux.8.gz
/usr/share/man/man8/nfs_selinux.8.gz       /usr/share/man/man8/ypbind_selinux.8.gz
/usr/share/man/man8/nis_selinux.8.gz


Version-Release number of selected component (if applicable):
selinux-policy-strict-1.25.4-8

How reproducible:
Didn't try

Steps to Reproduce:

  

Additional info:
Comment 1 Daniel Walsh 2005-09-27 15:48:28 EDT
This is because you are using two different versions of policy.  Update both at
the same time.  The only time this would happen is if the man pages change.

Dan
Comment 2 Ivan Gyurdiev 2005-09-27 17:04:25 EDT
> This is because you are using two different versions of policy. 

According to current packaging, there's nothing wrong with using several version
of the policy simultaneously (they're set up for parallel install).

However when you try to update them, rpm reports an error condition, which
indicates a problem, confusing the user. I agree that this isn't a very
important bug, bug IMHO it's still a bug - if the documentation is shared, it
should be in a shared package. If it is per policy, per policy manpages should
be installed, so they can be changed independently without a conflict.

Your decision...leaving bug as closed.
Comment 3 Ivan Gyurdiev 2005-10-01 23:39:37 EDT
I should note that this will block the yum transaction, preventing a yum upgrade
for people with multiple versions of policy installed...



Note You need to log in before you can comment on or make changes to this bug.