Bug 169219 - allow overriding $basearch, $releasever from command line
allow overriding $basearch, $releasever from command line
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-25 04:47 EDT by Avi Kivity
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-25 08:51:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2005-09-25 04:47:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
yum is very useful for creating nfs images, as in:  
  
  yum --installroot=/path/to/my/image groupinstall base  
  
unfortunately, that doesn't work when creating an i386 image on an x86_64  
machine, because yum takes $basearch from the host system (using dstroverpkg)  
instead of the installed system (which doesn't exist yet).  
  
a workaround is to replace $basearch with your favorite arch in the 
repositories configuration, but of course we don't want to do that. 
 
a similar problem occurs when creating an nfs image for, say, FC4, on an FC3 
machine. again, yum will substitute the host machine's $releasever instead of 
the target. 
 
one solution would be to allow setting these variables from the command line: 
 
  yum --installroot=/path/to/my/image --basearch=i386 --releasever=4 
groupinstall base  
 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A    

Actual Results:  N/A 

Expected Results:  N/A 

Additional info:
Comment 1 Seth Vidal 2005-09-25 08:51:27 EDT
you should be able to do most of this with a yum plugin. See the yum-utils
package for example of plugins.

Note You need to log in before you can comment on or make changes to this bug.