Bug 169236 - New version of SpamAssassin available (3.1.0)
New version of SpamAssassin available (3.1.0)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
http://svn.apache.org/repos/asf/spama...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-25 17:33 EDT by Milan Kerslager
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 11:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2005-09-25 17:33:56 EDT
New SpamAssassin 3.1.0 introduces a lot of changes (mostly move to plugins).
Will be there a new fersion for FC4 or 3.1.x is supposed to be in FC5 only? Are
there some issues for FC4?
Comment 1 Warren Togami 2005-09-25 20:02:12 EDT
FC3 and FC4 will remain at 3.0.x while FC5 has 3.1.x.  I am in the middle of
backporting many fixes from 3.1.x to a future 3.0.5 release.  FC3 and FC4 will
have an intermediate 3.0.4 + patches and 3.0.5 final.  No time estimates on when
this will happen.
Comment 2 Darren Brierton 2005-10-31 10:46:35 EST
Warren, is there any news on a spamassassin update for FC4? My current
spamassassin-3.0.4-1.fc4 is letting more and more spam through now, even though
I'm training it on all the false negatives. I had nearly two hundred spam
messages in my inbox this morning ... Please help, I'm getting desperate!
Comment 3 Kenneth Porter 2005-10-31 12:24:27 EST
I'm using 3.1.0 on my FC2 servers, built as an RPM from the tarball at the SA
website. Works just fine. I'd recommend grabbing the SRPM from
Fedora-development and repackaging to FC4.

Repackaging is relatively easy to do, almost as easy as configure/make from a
tarball. If you have multiple packagers on your system, you need to set up an
RPM build environment for each in his home directory. (Relatively easy, make
directories and a .rpmmacros file for each packager.) If you're the only one on
your system, just use the default tree and macros: chown the /usr/src/redhat
tree to your login, and run "rpmbuild --rebuild some-source-package.src.rpm" and
you'll find your shiny new binary RPM in /usr/src/redhat/RPMS ready to install.
Comment 4 Warren Togami 2005-10-31 14:01:50 EST
http://people.redhat.com/wtogami/temp/spamassassin-3.0.4-1.fc4.test1.src.rpm
Please rebuild and test this RPM where I had backported many bug fixes from
3.1.0.  In the short-term FC3 and FC4 will have a 3.0.5 update.  Among these
backported patches are things that solve a few holes that spammers were using to
trick the spam filter.

You may want to try augmenting spamassassin with the three network hash testers,
pyzor, razor and dcc.  You can install the first two with "yum install pyzor
perl-Razor-Agent", but dcc we couldn't add to Extras because of its non-Open
Source license.  Each user that uses it must then run "razor-admin -register" to
create a razor account for use.  spamassassin will automatically detect the
existence of these tool and use them to enhance the classification score.

And yes, rebuilding rawhide's 3.1.0 RPM to run your FC3 of FC4 would also work.
Comment 5 Darren Brierton 2005-10-31 14:16:38 EST
Re rebuilding rawhide's SRPM (in comments #3 and #4): that didn't work here.
Processing failed with messages in /var/log/maillog like:

Oct 31 18:06:41 excession spamd[15318]: Can't locate Mail/SPF/Query.pm in @INC
(@INC contains: ../lib /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.6/i386-linux-thread-multi /usr/lib/perl5/5.8.6) at
/usr/lib/perl5/vendor_perl/5.8.6/Mail/SpamAssassin/Plugin/SPF.pm line 272,
<GEN15> line 103.

Re comment #14, Warren I will test your package tomorrow. Thank you. In the
meantime I'll see if installing pyzor and razor help overnight.
Comment 6 Ville Skyttä 2005-10-31 15:27:02 EST
BTW, and a bit OT: enhancing Evolution's built-in default spam filtering with  
pyzor/razor/etc doesn't work; if I understand correctly, Evo insists on 
finding a spamd running with --local/-L, or starts a new network-disabled 
private instance if it doesn't find one. 
Comment 7 Darren Brierton 2005-10-31 15:41:53 EST
RE comment #6: actually in my case procmail is calling spamc via the includerc
file in /etc/mail/spamassassin/spamassassin-spamc.rc, and the pyzor/razor tests
fail due, I believe to selinux. This is an excerpt from /var/log/maillog:

Oct 31 20:37:02 excession spamd[15656]: razor2 check skipped: Permission denied
IO::Socket::INET: connect: Permission denied at
/usr/lib/perl5/vendor_perl/5.8.6/Mail/SpamAssassin/Dns.pm line 447, <GEN321>
line 42.

Not sure where to file this, under Fedora Core selinux, or Fedora Extras
perl-Razor-Agent.
Comment 8 Warren Togami 2005-10-31 15:47:23 EST
Darren your problem is maybe Bug #171903 or Bug #172088.
Comment 9 Darren Brierton 2005-10-31 16:00:12 EST
(In reply to comment #8)
> Darren your problem is maybe Bug #171903 or Bug #172088.

Right. Also (while on the topic of selinux and spamassassin) see Bug #171194.
Comment 10 Warren Togami 2005-11-09 12:42:32 EST
http://people.redhat.com/wtogami/temp/spamassassin/fc3/
http://people.redhat.com/wtogami/temp/spamassassin/fc4/

Please help me to test this package that will soon go to FC3 and FC4 updates. 
It is essentially an upstream 3.0.5 release candidate.
Comment 11 Warren Togami 2006-06-07 11:19:40 EDT
I've given up on updating to 3.1.x in FC4 because of the spamd scaling problem.

Note You need to log in before you can comment on or make changes to this bug.