Bug 169276 - gnome-pilot-version not substituted in .spec file
gnome-pilot-version not substituted in .spec file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-pilot-conduits (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-09-26 09:07 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0001
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:30:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-09-26 09:07:24 EDT
$ rpm -q gnome-pilot-conduits
gnome-pilot-conduits-2.0.12-3
$ rpm -q --requires gnome-pilot-conduits | grep version
gnome-pilot >= %{gnome-pilot-version}

This will cause problems during installation if gnome-pilot-conduits is
required, as anaconda doesn't expect a '%' as part of the version required.
Comment 7 Dave Malcolm 2005-10-24 17:29:43 EDT
Problem appears to be that rpm build is not substituting macros containing dash
characters; replacing with an underscore fixes it.

Problem also affects FC3, FC4 and latest FC5 spec file.

Fixing for RHEL4 as 2.0.12-4.EL4
Fixing in rawhide for FC5 as 2.0.13-2.FC5
Comment 12 Red Hat Bugzilla 2006-03-07 11:37:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0001.html
Comment 13 Red Hat Bugzilla 2006-03-07 13:30:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0001.html

Note You need to log in before you can comment on or make changes to this bug.