Bug 169280 - gnome-panel wnck applets crash on login
gnome-panel wnck applets crash on login
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gtk+ (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 169281 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-09-26 10:07 EDT by Philip Morano
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2005-795
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:27:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
applet fails to load (47.24 KB, image/jpeg)
2005-09-28 13:48 EDT, John Poelstra
no flags Details
all three applets that fail (76.53 KB, image/jpeg)
2005-09-28 13:48 EDT, John Poelstra
no flags Details
When reading size hints from swallowed windows, validate and clamp as neccessary (750 bytes, patch)
2005-10-03 10:53 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description Philip Morano 2005-09-26 10:07:45 EDT
I updated to the latest asynchronous updates on Friday and sense then every time
I login some of my panel applets crash immediately.  In particular, my "Show
Desktop" button, my window list, and my windows switcher crash.  I removed them
from my panel, brought up a terminal and ran /usr/libexec/wnck-applet then
readded them.  They came up, but the follow messages spewed to the console:

(wnck-applet:4120): GConf-CRITICAL **: file gconf-client.c: line 547 (gconf_clie
nt_add_dir): assertion `gconf_valid_key (dirname, NULL)' failed

** (wnck-applet:4120): CRITICAL **: file panel-applet.c: line 801 (panel_applet_
get_pixmap): assertion `pixmap != NULL' failed

** (wnck-applet:4120): WARNING **: Failed to get pixmap 14684571,527,0

** (wnck-applet:4120): CRITICAL **: file panel-applet.c: line 801 (panel_applet_
get_pixmap): assertion `pixmap != NULL' failed

** (wnck-applet:4120): WARNING **: Failed to get pixmap 14684584,527,0

I don't think the panel was updated on Friday, so I'm not sure what is going on.
Comment 1 Philip Morano 2005-09-26 10:08:40 EDT
Some information that might be useful:

gnome-panel-2.8.1-3.3E
libwnck-2.8.1-1
Comment 2 John Poelstra 2005-09-28 13:47:32 EDT
seeing same problem with fresh install of RHEL4-U2-RC2 on x86_64 box (Dell
Precision 470 desktop).  Also attaching screen shots.

I reproduced twice in a row.

1) Full install (once from CD; once via NFS)
2) Answer firstboot questions
3) Login from gdm
Comment 3 John Poelstra 2005-09-28 13:48:19 EDT
Created attachment 119378 [details]
applet fails to load
Comment 4 John Poelstra 2005-09-28 13:48:51 EDT
Created attachment 119379 [details]
all three applets that fail
Comment 5 Mark McLoughlin 2005-09-28 14:08:10 EDT
Ray: could this be a recent libwnck change?
Comment 6 Ray Strode [halfline] 2005-09-28 15:06:47 EDT
Hi Mark,

interestingly enough it looks like it may be a libgnome gconf escaping issue. 
poelstra just pulled me to his cube and showed me the problem on his freshly
installed U2 box.  I think I have a fix.
Comment 7 Ray Strode [halfline] 2005-09-28 16:15:44 EDT
Ah, so apparently X won't allow clients to create absurdly large pixmaps anymore
as of the last update.

** (wnck-applet:4120): WARNING **: Failed to get pixmap 14684571,527,0

Soeren is going to post details.
Comment 8 Søren Sandmann Pedersen 2005-09-28 16:23:32 EDT
One of the things the X update does is return BadAlloc when a client tries to
allocate a pixmap with a height or width of more than 32767.

This:

** (wnck-applet:4120): WARNING **: Failed to get pixmap 14684584,527,0

looks like it could be related. 
Comment 9 Philip Morano 2005-09-29 08:28:50 EDT
For what it is worth, I found that if I do not start the applets when I log in,
but start them after the session is established, then everything works fine
Comment 10 Rob Kenna 2005-09-29 13:51:47 EDT
I have seen the same problem as Phil.  It also persists, but in a random fashion.

I also have a problem where when I double click on a message the window is
created, but invisible.  If I create it w/ a right-mouse selection it correctly
pops up.  Perhaps Thunderbird is asking for a crazy pixmap size.  Maybe it's a
different issue altogether.

(I sit in Westford)
Comment 11 Ray Strode [halfline] 2005-09-30 00:20:49 EDT
So this is a problem in gtk socket's size request code.  Negative size hints on
the plug window get stored unsigned instead of clamped to 1.
Comment 12 Rob Kenna 2005-09-30 10:02:22 EDT
re: Comment #10

I sorted out my missing "pop up" window problem.  "Spanning desktop" got set on
my dual monitor mode config.  The window was popping up on the other monitor
which happened not to be there.  doh!
Comment 16 Ray Strode [halfline] 2005-10-03 10:53:21 EDT
Created attachment 119550 [details]
When reading size hints from swallowed windows, validate and clamp as neccessary

The above patch addresses this bug by clamping size hints read from toplevel
windows that are swallowed by GtkSocket widgets to non-negative values.
Comment 17 Red Hat Bugzilla 2005-10-05 13:27:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-795.html
Comment 18 Mike A. Harris 2006-03-28 07:41:02 EST
*** Bug 169281 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.