Bug 169283 - savage driver 1.1.27mh hang
savage driver 1.1.27mh hang
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: XFree86 (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 10:48 EDT by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 13:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2005-09-26 10:48:15 EDT
+++ This bug was initially created as a clone of Bug #168766 +++

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
Whenever this test program is executed, the system does hang. 


Version-Release number of selected component (if applicable):
XFree86-4.3.0-81.EL

How reproducible:
Always

Steps to Reproduce:
1. install drawline.tar.gz
2. execute drawline

  

Actual Results:  system is hung.

Expected Results:  Savage driver works. 

Additional info:

-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 03:50 EST --
Created an attachment (id=119015)
test program


-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 03:54 EST --
Created an attachment (id=119016)
patch


-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 03:59 EST --
Issue of hang is corrected with this patch. 


-- Additional comment from mharris@redhat.com on 2005-09-20 04:17 EST --
Thanks for the report.  I've reviewed the patch, and have some questions:


Where did the patch originate?  It contains a number of changes which don't
actually do anything, ie:

-unsigned
+unsigned int

Curious if you got this from somewhere on the net, or from XFree86 or X.Org
CVS, or somewhere else?

+#if 0
 static void SavageSubsequentSolidTwoPointLine(


This will disable 2 point lines on all savage hardware.  Instead of this,
does using the XaaNoSolidTwoPointLine option with the stock Red Hat driver
yield the same result?

Some of the changes in the patch seem harmless, while other parts of the
patch touch code which is shared among different savage hardware, and of
which it is unclear as to the effect they might have on other Savage
hardware.

In addition to the above questions, please attach your X server log from
before and after this patch for review.

Thanks in advance.


Setting status to "NEEDINFO_REPORTER".  

-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 04:38 EST --
This patch is not original. 
It is backported from savage driver 1.1.27 of RHEL4.
The cause of this issue is xaaptr->SolidBresenhamLineErrorTermBits = 14.
TermBit=14 will generate overfllow of the BCI command.
It should be xaaptr->SolidBresenhamLineErrorTermBits = 13.
I consented for the log. Please wait until tomorrow. 

Thanks.


 

-- Additional comment from mharris@redhat.com on 2005-09-20 17:36 EST --
Thanks.  We'll review the patch in greater depth, and do a risk analysis for
consideration in a future update.



-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 23:24 EST --
(In reply to comment #6)
> Thanks.  We'll review the patch in greater depth, and do a risk analysis for
> consideration in a future update.

Thanks. Please contact me if there is an update. 
BTW, this isseu is solved with the following patches. 
(See attached file: patch.tar.gz)

diff -urN xc/programs/Xserver/hw/xfree86/drivers/savage.orig/savage_accel.c 
xc/programs/Xserver/hw/xfree86/drivers/savage/savage_accel.c
--- xc/programs/Xserver/hw/xfree86/drivers/savage.orig/savage_accel.c	2005-09-
20 17:41:38.000000000 +0900
+++ xc/programs/Xserver/hw/xfree86/drivers/savage/savage_accel.c	2005-09-
20 17:43:26.000000000 +0900
@@ -485,7 +485,7 @@
     xaaptr->SubsequentSolidFillTrap = SavageSubsequentSolidFillTrap; 
 #endif
 
-    xaaptr->SolidBresenhamLineErrorTermBits = 14;
+    xaaptr->SolidBresenhamLineErrorTermBits = 13;
 #endif
 
     /* ImageWrite */

 




-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 23:33 EST --
Created an attachment (id=119060)
The patches were attached.


-- Additional comment from haruo.tomita@toshiba.co.jp on 2005-09-20 23:34 EST --
Created an attachment (id=119061)
The log was attached.

Note You need to log in before you can comment on or make changes to this bug.