Bug 169305 - galeon needs to be recompiled for mozilla 1.7.12
galeon needs to be recompiled for mozilla 1.7.12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 16:35 EDT by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 18:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-09-26 16:35:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Galeon/1.3.21

Description of problem:
Yet again mozilla has been updated and galeon needs recompiled.

Version-Release number of selected component (if applicable):
galeon-1.3.21-13.fc4

How reproducible:
Always

Steps to Reproduce:
1. yum update
  

Actual Results:  Error: Missing Dependency: mozilla = 37:1.7.10 is needed by package galeon


Expected Results:  No errors along with mozilla and galeon updated

Additional info:
Comment 1 Joe Harrington 2005-09-29 12:17:06 EDT
Please make sure it gets rebuilt for FC3, as well.

I don't know the internals of the RH build systems, but it would be useful for
nightly updaters, and labor-saving for RH, to automate the rebuilding of
dependent packages, even when the dependency is across repos.  For example,
whenever mozilla gets rebuilt, galeon should too, automatically.  That way,
galeon will never again hold up our system updates, as it is famous for doing. 
I'm sure there must be other packages that would benefit, as well.

Thanks,

--jh--
Comment 2 Alex Lancaster 2005-10-01 21:02:33 EDT
I think Dams has more or less orphaned galeon.  I volunteered to maintain it
only in the worst case if nobody else did, but Dennis Leroy recently volunteered
on the fedora-extras mailing list:

http://www.redhat.com/archives/fedora-extras-list/2005-September/msg01447.html

Comment 3 Alex Lancaster 2005-10-01 21:11:36 EDT
> I don't know the internals of the RH build systems, but it would be useful for
> nightly updaters, and labor-saving for RH, to automate the rebuilding of
> dependent packages, even when the dependency is across repos.  For example,
> whenever mozilla gets rebuilt, galeon should too, automatically.  That way,
> galeon will never again hold up our system updates, as it is famous for doing. 
> I'm sure there must be other packages that would benefit, as well.

Great idea, but I think the problem is that the version of galeon needs to be
hardcoded in the spec file (at least in the current implementation of the FE
buildsystem).  See the (quite long) previous discussion of this at: bug #164344.
 Warren Togami was advocating this approach.

Comment 4 Alex Lancaster 2005-10-01 21:13:57 EDT
(In reply to comment #3)
 
> Great idea, but I think the problem is that the version of 
> galeon needs to be
  ^^^^^^^

Of course, I mean the current version of *mozilla* (that galeon depends on).


Comment 5 Denis Leroy 2005-10-03 17:04:10 EDT
Yes, i'm happy to take over the maintenance of galeon. I'll fix this later
today, it should be a simple version bump-up and build requests. This affects
FC3, FC4 and devel.
Comment 6 Denis Leroy 2005-10-05 18:06:54 EDT
For some reason, i can't reassign this bug to me nor close it. Someone please
close it thanks, new RPMS were released today.
Comment 7 Michael Schwendt 2005-10-05 18:43:59 EDT
You need to request membership in fedorabugs group in the accounts
system.
Comment 8 Christopher Beland 2005-10-06 20:13:02 EDT
Thank you!  The recompliation was eagerly awaiting and greatly appreciated.

Note You need to log in before you can comment on or make changes to this bug.