Bug 169307 - qmgr exits causing all messages to be defered
Summary: qmgr exits causing all messages to be defered
Status: CLOSED DUPLICATE of bug 169308
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL: https://mailguard.ucar.edu/mailguard/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-26 20:53 UTC by Greg Woods
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 09:09:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Woods 2005-09-26 20:53:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
The attached spam, when inserted into the active queue spool area, causes qmgr to exit, leaving the system in a state where it will accept messages but nothing is delivered. A corrupt mail *should* get moved to the corrupt area and should not cause all delivery through the system to cease. Here is the log entry:

Sep 26 09:04:37 mscan6 postfix/qmgr[18101]: fatal: bad extra offset  file active
/2/2DE3E114020
Sep 26 09:04:38 mscan6 postfix/master[18036]: warning: process /usr/libexec/post
fix/qmgr pid 18101 exit status 1

The system tries to restart qmgr, but it exits as soon as it hits this message again, and nothing queued behind it is ever delivered.

Version-Release number of selected component (if applicable):
postfix-2.1.5-5

How reproducible:
Always

Steps to Reproduce:
1.Stop postfix
2.Place the queue file referenced by the above URL into /var/spool/postfix/active/2/2DE3E114020
3. Restart postfix
  

Actual Results:  Sep 26 09:04:37 mscan6 postfix/qmgr[18101]: fatal: bad extra offset  file active
/2/2DE3E114020
Sep 26 09:04:38 mscan6 postfix/master[18036]: warning: process /usr/libexec/post
fix/qmgr pid 18101 exit status 1

Expected Results:  I would have expected a corrupt message to be moved under /var/spool/postfix/corrupt so that remaining queued messages could be delivered.

Additional info:

It's a high priority problem when it happens, but it's only happened once in more than a year of running this system.

Comment 1 Thomas Woerner 2005-09-27 09:09:26 UTC

*** This bug has been marked as a duplicate of 169308 ***


Note You need to log in before you can comment on or make changes to this bug.